MyBB Community Forums
A few issues with &lt's appearing for no reason - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Themes (https://community.mybb.com/forum-103.html)
+---- Forum: Theme Support (https://community.mybb.com/forum-10.html)
+---- Thread: A few issues with &lt's appearing for no reason (/thread-95165.html)



A few issues with &lt's appearing for no reason - xomp - 2011-05-26

I've really no idea why this suddenly cropped up, but I have suddenly seemed to have a lot of &lt's or "<" appear on my threads for no apparent reason.

Anyone know whats causing this and how to fix?


RE: A few issues with &lt's appearing for no reason - Yaldaram - 2011-05-26

These characters are in "forumdisplay_threadlist" template, search and remove it from there. Or if you wish you can paste the entire code from that template here, and I'll try to search and remove them =)


RE: A few issues with &lt's appearing for no reason - faviouz - 2011-05-26

Do you have Codepress enabled? It's recommended to have it disabled, because it's really buggy and old. To disable it:

Admin CP > Preferences > Turn on / off Codepress > Off.

(this won't fix already existing code, but only future edits, if, of course, that was the issue)


RE: A few issues with &lt's appearing for no reason - xomp - 2011-05-26

(2011-05-26, 06:51 PM)Yaldaram Wrote: These characters are in "forumdisplay_threadlist" template, search and remove it from there. Or if you wish you can paste the entire code from that template here, and I'll try to search and remove them =)

I figured it was there Smile Here is the forumdisplay_threadlist template code:
<div class="float_left">
	{$multipage}
</div>
<div class="float_right">
	{$newthread}
</div>
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder" style="clear: both;">
	<tr>
		<td class="thead" colspan="{$colspan}">
			<div style="float: right;">
				<span class="smalltext"><strong><a href="misc.php?action=markread&amp;fid={$fid}{$post_code_string}">{$lang->markforum_read}</a> | <a href="usercp2.php?action={$add_remove_subscription}subscription&amp;type=forum&amp;fid={$fid}&amp;my_post_key={$mybb->post_code}">{$add_remove_subscription_text}</a>{$clearstoredpass}</strong></span>
			</div>
			<div>
				<strong>{$foruminfo['name']}</strong>
			</div>
		</td>
	</tr>
	<tr>
		<td class="tcat" colspan="1" width="66%"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=subject&amp;order=asc">{$lang->thread}</a> {$orderarrow['subject']} / <a href="{$sorturl}&amp;sortby=starter&amp;order=asc">{$lang->author}</a> {$orderarrow['starter']}</strong></span></td>
		<td class="tcat" align="center" width="7%"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=replies&amp;order=desc">{$lang->replies}</a> {$orderarrow['replies']}</strong></span></td>
		<td class="tcat" align="center" width="7%"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=views&amp;order=desc">{$lang->views}</a> {$orderarrow['views']}</strong></span></td>
		{$ratingcol}
		<td class="tcat" align="right" width="20%"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=lastpost&amp;order=desc">{$lang->lastpost}</a> {$orderarrow['lastpost']}</strong></span></td>
		{$inlinemodcol}
	</tr>
	{$selectall}
	{$announcementlist}
	{$threads}
	<tr>
		<td class="tfoot" align="right" colspan="{$colspan}">
			<form action="forumdisplay.php" method="get">
				<input type="hidden" name="selectall" value="{$allselected}" />
				<input type="hidden" name="fid" value="{$fid}" />
				<select name="sortby">
					<option value="subject" {$sortsel['subject']}>{$lang->sort_by_subject}</option>
					<option value="lastpost" {$sortsel['lastpost']}>{$lang->sort_by_lastpost}</option>
					<option value="starter" {$sortsel['starter']}>{$lang->sort_by_starter}</option>
					<option value="started" {$sortsel['started']}>{$lang->sort_by_started}</option>
					{$ratingsort}
					<option value="replies" {$sortsel['replies']}>{$lang->sort_by_replies}</option>
					<option value="views" {$sortsel['views']}>{$lang->sort_by_views}</option>
				</select>
				<select name="order">
					<option value="asc" {$ordersel['asc']}>{$lang->sort_order_asc}</option>
					<option value="desc" {$ordersel['desc']}>{$lang->sort_order_desc}</option>
				</select>
				<select name="datecut">
					<option value="1" {$datecutsel['1']}>{$lang->datelimit_1day}</option>
					<option value="5" {$datecutsel['5']}>{$lang->datelimit_5days}</option>
					<option value="10" {$datecutsel['10']}>{$lang->datelimit_10days}</option>
					<option value="20" {$datecutsel['20']}>{$lang->datelimit_20days}</option>
					<option value="50" {$datecutsel['50']}>{$lang->datelimit_50days}</option>
					<option value="75" {$datecutsel['75']}>{$lang->datelimit_75days}</option>
					<option value="100" {$datecutsel['100']}>{$lang->datelimit_100days}</option>
					<option value="365" {$datecutsel['365']}>{$lang->datelimit_lastyear}</option>
					<option value="9999" {$datecutsel['9999']}>{$lang->datelimit_beginning}</option>
				</select>
				{$gobutton}
			</form>
		</td>
	</tr>
</table>
<div class="float_left">
	{$multipage}
</div>
<div class="float_right" style="margin-top: 4px;">
	{$newthread}
</div>
<br style="clear: both;" />
<br />

<div class="float_right" style="text-align: right;">
	{$inlinemod}
	{$searchforum}
	{$forumjump}
</div>
<br style="clear: both" />
{$inline_edit_js}

(2011-05-26, 06:57 PM)faviouz Wrote: Do you have Codepress enabled? It's recommended to have it disabled, because it's really buggy and old. To disable it:

Admin CP > Preferences > Turn on / off Codepress > Off.

(this won't fix already existing code, but only future edits, if, of course, that was the issue)

Thanks! This was turned "On" I've now disabled it.



RE: A few issues with &lt's appearing for no reason - xomp - 2011-05-27

I still can't seem to find these "< < < < < < <" in any template Sad Can someone pickup where we left off? Thanks


RE: A few issues with &lt's appearing for no reason - - G33K - - 2011-05-28

The problem is probably in the forumdisplay_thread template.
Could we have your forumdisplay_thread template?


RE: A few issues with &lt's appearing for no reason - xomp - 2011-05-28

(2011-05-28, 02:02 AM)- G33K - Wrote: The problem is probably in the forumdisplay_thread template.
Could we have your forumdisplay_thread template?

Certainly! here it is:

<tr>
	<td class="{$bgcolor}{$thread_type_class}">
	{$attachment_count}	
<div>
            <table><tr><td id="tvatar">{$thread_avatar}</td><td>{$prefix} {$gotounread}{$thread['threadprefix']}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}<br><font color="grey">created by:</font> {$thread['profilelink']}</td></tr></table>        
        </div>
	<td align="center" class="{$bgcolor}{$thread_type_class}"><a href="javascript:MyBB.whoPosted({$thread['tid']});">{$thread['replies']}</a>{$unapproved_posts}</td>
	<td align="center" class="{$bgcolor}{$thread_type_class}">{$thread['views']}</td><
	{$rating}
	<td class="{$bgcolor}{$thread_type_class}" style="white-space: nowrap; text-align: right;">
		<span class="lastpost smalltext">{$lastpostdate} {$lastposttime}<br />
		<a href="{$thread['lastpostlink']}">{$lang->lastpost}</a>: {$lastposterlink}</span>
	</td>
{$modbit}
</tr>



RE: A few issues with &lt's appearing for no reason - - G33K - - 2011-05-28

Replace forumdisplay_thread with this:

<tr>
    <td class="{$bgcolor}{$thread_type_class}">
    {$attachment_count}    
<div>
            <table><tr><td id="tvatar">{$thread_avatar}</td><td>{$prefix} {$gotounread}{$thread['threadprefix']}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}<br><font color="grey">created by:</font> {$thread['profilelink']}</td></tr></table>        
        </div>
    <td align="center" class="{$bgcolor}{$thread_type_class}"><a href="javascript:MyBB.whoPosted({$thread['tid']});">{$thread['replies']}</a>{$unapproved_posts}</td>
    <td align="center" class="{$bgcolor}{$thread_type_class}">{$thread['views']}</td>
    {$rating}
    <td class="{$bgcolor}{$thread_type_class}" style="white-space: nowrap; text-align: right;">
        <span class="lastpost smalltext">{$lastpostdate} {$lastposttime}<br />
        <a href="{$thread['lastpostlink']}">{$lang->lastpost}</a>: {$lastposterlink}</span>
    </td>
{$modbit}
</tr> 



RE: A few issues with &lt's appearing for no reason - xomp - 2011-05-28

(2011-05-28, 02:32 AM)- G33K - Wrote: Replace forumdisplay_thread with this:

<tr>
    <td class="{$bgcolor}{$thread_type_class}">
    {$attachment_count}    
<div>
            <table><tr><td id="tvatar">{$thread_avatar}</td><td>{$prefix} {$gotounread}{$thread['threadprefix']}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}<br><font color="grey">created by:</font> {$thread['profilelink']}</td></tr></table>        
        </div>
    <td align="center" class="{$bgcolor}{$thread_type_class}"><a href="javascript:MyBB.whoPosted({$thread['tid']});">{$thread['replies']}</a>{$unapproved_posts}</td>
    <td align="center" class="{$bgcolor}{$thread_type_class}">{$thread['views']}</td>
    {$rating}
    <td class="{$bgcolor}{$thread_type_class}" style="white-space: nowrap; text-align: right;">
        <span class="lastpost smalltext">{$lastpostdate} {$lastposttime}<br />
        <a href="{$thread['lastpostlink']}">{$lang->lastpost}</a>: {$lastposterlink}</span>
    </td>
{$modbit}
</tr> 

It's fixed! I thank you so much G33K! Whatever bit of magic you did was truly awesome Smile