MyBB Community Forums
Getting frustrated with these problems - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.2 Series (https://community.mybb.com/forum-3.html)
+------ Forum: MyBB 1.2 General Support (https://community.mybb.com/forum-4.html)
+------ Thread: Getting frustrated with these problems (/thread-9771.html)

Pages: 1 2


Getting frustrated with these problems - Syzygy - 2006-06-15

I posted a little while back about an editing problem I was having. Often when editing posts, the post was truncated down to the first sentence. So a five or ten-sentence post would be cut down to one or two sentences.

I've noticed this problem cropping up in different ways now. Sometimes when posting a new message, the message gets cropped down to one or two sentences. I can't verify, but this seems to occur primarily when using the main reply page (and not the quick reply field), and more often in Safari than Firefox.

When moving posts from one forum to another, MyBB has a tendency to "forget" about some of the posts. I can check 7 posts and find only 5 have been moved.

All the problems are in this general vein. Stuff only gets "half-done." Is my server too slow? (533 MHz PIII, 256 MB RAM, serving about 5-10 people simultaneously) Is my software configuration incorrect? (Apache 2, PHP 5, MySQL 4)

This is really starting to get at me, this "phantom problem," and I'd like to solve it once and for all.


RE: Getting frustrated with these problems - Ryan Gordon - 2006-06-15

You appear to be the only one out of thousands of board users to be experiencing these problems


RE: Getting frustrated with these problems - zaher1988 - 2006-06-15

Happend actually sometime before, look here.

Could you please provide us with a link for your forum.

regards


RE: Getting frustrated with these problems - Dennis Tsang - 2006-06-15

Is there a pattern to what is being truncated?

zaher1988 Wrote:Happend actually sometime before, look here.
It's the same person Rolleyes


RE: Getting frustrated with these problems - zaher1988 - 2006-06-15

ooops!! :$
* zaher1988 will never come back to mybb unless 24 hours are passed.


RE: Getting frustrated with these problems - Syzygy - 2006-06-15

http://www.retiredsquirrels.com/forum

The truncation appears to be on complete sentences. I've never (maybe once or twice? don't remember) seen it truncate midway through a sentence. My members have expressed frustration, saying things like "I just delete punctuation until it stops cutting my posts short." And as we all know, posts without punctuation are a bad thing. Toungue

If I'm the only one experiencing these problems, let's look at what's unique about my setup...

- I used a phpBB -> MyBB conversion script after a fresh install. It had one error during the process relating to posts from anonymous users, which I fixed up in the script's code, then continued the conversion process. (BTW, kudos for having an easily understandable database schema.)

- When I realized I had set up my groups incorrectly, I used some SQL to fix it up. All I did was change around the primary groups and secondary groups (everyone of a given secondary group had that group become its primary).

- I host on a fairly slow home network on a fairly slow home computer. MyBB is slower than phpBB was, probably because it's more processor intensive, but not intolerably so.

- My server is running Gentoo Linux:

[email protected] ~ $ uname -a
Linux www 2.6.16-gentoo-r9 #1 PREEMPT Tue Jun 6 00:15:00 PDT 2006 i686 Pentium III (Coppermine) GNU/Linux
[email protected] ~ $ mysql -V
mysql  Ver 14.7 Distrib 4.1.20, for pc-linux-gnu (i686) using readline 5.1
[email protected] ~ $ /usr/sbin/apache2 -V
Server version: Apache/2.0.55
Server built:   May  9 2006 10:56:14
Server's Module Magic Number: 20020903:11
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr"
 -D SUEXEC_BIN="/usr/sbin/suexec2"
 -D DEFAULT_PIDLOG="/var/run/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="/var/run/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
 -D SERVER_CONFIG_FILE="/etc/apache2/httpd.conf"
[email protected] ~ $ php -v
PHP 5.1.4-pl0-gentoo (cli) (built: May  9 2006 01:31:42) 
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies



RE: Getting frustrated with these problems - Syzygy - 2006-06-15

Oooh, I have an idea. I can set up another forum on the same server, with open admin privileges, if you guys think it would help.


RE: Getting frustrated with these problems - Dennis Tsang - 2006-06-15

I made two threads on your forum:
http://www.retiredsquirrels.com/forum/showthread.php?tid=1813
http://www.retiredsquirrels.com/forum/showthread.php?tid=1812

Nothing seems to be truncated.

Do you have an example post that got truncated? (The exact message that didn't work)


RE: Getting frustrated with these problems - Syzygy - 2006-06-15

Yes, see http://community.mybboard.net/showthread.php?tid=9115

I think it's primarily due to server load. A similar problem that occurs only in Safari is pages rendering incorrectly -- Safari will prematurely truncate pages or misformat pages due to improperly loaded HTML. This is most likely Safari "giving up" on loading the rest of the page or some such. I've noticed this happens when the server is under high load.

It's worth mentioning that the truncation error occurs not just in Safari though; all of my members are reporting it and only a few of them are Mac users.

EDIT: Pics of the Safari issue, so you understand it's different from a simple timeout:

http://web.mac.com/nicoleconary/iWeb/me/screenshots.html


RE: Getting frustrated with these problems - Syzygy - 2006-06-15

Oooh, if you notice, helpful board member Stalebuff has replicated the problem trying to quote your post on my forum. I leave the thread untouched for your perusal. Smile

Is there any PHP logging statements you would like me to inject, or SQL commands to run, or anything like that? I'm handy with a terminal and I know my way around LAMP.