Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 4 Months ago MyBB 1.8 Promotion system not working
#1
Solved: 4 Years, 4 Months ago
Hello.
I am using MyBB's promotion system on my site. When a user comes and registers on site, it is placed in an initial group. So when he successfully makes 5 or more posts, he should be promoted to next group where almost all the things are allowed to him.

So I set up the promotion system from ACP >> Users & Groups >> Group Promotions.
I set "Promotion Requirement" to "Post Count" and in "Post Count" text field below, I added 5 and set next drop down to "Greater than" and added rest of the required info as well.

I checked task in Task Manager, task is active and runs each 20 mins and even I ran it some times manually as well. The issue is, users do not get promoted to next rank.

Is there anything else I am missing ??
In case you think I have helped you, do not forget to add +rep.

Dota International - Your Daily Dota Doze
Reply
#2
Solved: 4 Years, 4 Months ago
i just tested ot in 1.8.3 and it works fine... is the Promotion System (not the Task) is "Enabled" and the "User Group Change Type" should be "Primary User Group".... can you share a screenshot of the settings page of the Promotion you have added...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't seen it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#3
Solved: 4 Years, 4 Months ago
I checked promotion logs (which I could not find earlier) and saw that promotions are done. But the thing is, in that "Display User Group" is still as per old usergroup. They are shown in site, as they are never promoted. Their custom usertitle, their name display style and user rank image are still of old usergroup. They have got other benefits of new group like PM capacity posting new thread etc, except display usergroup and its relevant issues.

How can I change that ?
In case you think I have helped you, do not forget to add +rep.

Dota International - Your Daily Dota Doze
Reply
#4
Solved: 4 Years, 4 Months ago
Sorry to bump , but im having the same issue here ,
"the thing is, in that "Display User Group" is still as per old usergroup. They are shown in site, as they are never promoted. Their custom usertitle, their name display style and user rank image are still of old usergroup. They have got other benefits of new group like PM capacity posting new thread etc, except display usergroup and its relevant issues."

Any ideas ?
Reply
#5
Solved: 4 Years, 4 Months ago
(03-28-2015, 10:28 AM)ShaneR82 Wrote: Sorry to bump , but im having the same issue here ,
"the thing is, in that "Display User Group" is still as per old usergroup. They are shown in site, as they are never promoted. Their custom usertitle, their name display style and user rank image are still of old usergroup. They have got other benefits of new group like PM capacity posting new thread etc, except display usergroup and its relevant issues."

Any ideas ?

I still have this issue, you will need to edit that manually for all users I guess.
Issue is that they get promoted as Additional user group, not as Primary user groups. If it is possible somehow that they  are promoted as Primary user groups, then their rank image and user title will show properly.
In case you think I have helped you, do not forget to add +rep.

Dota International - Your Daily Dota Doze
Reply
#6
Solved: 4 Years, 4 Months ago
Well, your users need to keep the default display group (Use Primary User Group option in ACP -> Edit User) and it will be updated then. Otherwise MyBB thinks the user wants to preserve the chosen display group and won't change it on promotions.

The only thing you can do is disabling display group modifications in ACP -> Groups -> [custom group] -> Yes, users can set this group as their display group
Reply
#7
Solved: 4 Years, 4 Months ago
My members are currently set to Display User Group >> Use Primary User Group (the group named 'Newbies'), so MyBB should not be thinking that it is attempting to change any other group other than what I have set. On top of that, my new members do not have any UserCP access to do so.

Meanwhile, I have set it up with only the following criteria:

Promotion Requirements >> Post Count
--- Only the post count option, no others...

Post Count >> Must be greater than 1
-- All other options, Thread Count, Reputation, etc... all set at 0.

Original User Group >> Newbies
New User Group >> Registered
User Group Change Type >> Primary User Group
--- Very Understandable

I have it set as Enabled, and with logging. And on seeing the above posts, I viewed the task manager which shows that the promotion system (ala promotions.php) is being performed in 20 minute intervals (specifically set to 5,25,45). Everything else being stock.

With this, the promotions system SHOULD run every 20 minutes and I should have new Registered members, but I do not. I have to manually update their status.

And before you ask, 'Run Task' on the promotions dropdown does not promote the members either.

EDIT: STUPIDITY. Kindly disregard (or place a kick me sign on my back)
Greater than or EQUAL TO '1' ..... for Posts of 1 or more.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)