Solved: 6 Years, 3 Months, 4 Weeks ago Codebuttons conflict?
Solved: 6 Years, 3 Months, 4 Weeks ago
I updated from 1.6.11 to 1.8.5 last night, and we're getting this funky error with our codebuttons. 
I am assuming it has something to do with a jquery conflict?

Inline moderation works after updating templates. 

I have enabled "Clickable MyCode Editor". I have also disabled it and re-enabled it.

The code buttons that alter text on-click (bold, italic, alignment) work. 
The code buttons that have drop downs or pop ups do not look right. They show up at the bottom left of the forum, unstyled. Them seem to function, however. 

Visual references: custom theme & default theme.
The code for them is there, they just... do not look right. Or show up at all. 

Codebuttons Code
<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/editor_themes/{$theme['editortheme']}" type="text/css" media="all" />
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js?ver=1805"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js?ver=1804"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/editor_plugins/undo.js?ver=1805"></script>
<script type="text/javascript">
var partialmode = {$mybb->settings['partialmode']},
opt_editor = {
plugins: "bbcode,undo",
style: "{$mybb->asset_url}/jscripts/sceditor/textarea_styles/jquery.sceditor.{$theme['editortheme']}",
rtl: {$lang->settings['rtl']},
locale: "mybblang",
enablePasteFiltering: true,
emoticonsEnabled: {$emoticons_enabled},
emoticons: {
// Emoticons to be included in the dropdown
dropdown: {
// Emoticons to be included in the more section
more: {
// Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
hidden: {
emoticonsCompat: true,
toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
$(function() {

MyBBEditor = $("#{$bind}").sceditor("instance");

Have I neglected to do something vital? :c Please help.

Edited to add that my modals are not working either, so logging in cannot be done through one.

Solution found:

Forum Jump:

Users browsing this thread: 1 Guest(s)