Solved: 5 Years, 1 Month, 4 Weeks ago bCrypt Causing Errors
#1
Solved: 5 Years, 1 Month, 4 Weeks ago
So I just followed this tutorial on installing bCrypt: http://community.mybb.com/thread-189672.html

I'm currently on a VPS and my PHP Version is 5.6.4 

The error I'm facing is simple. I can't log into my account and I know I'm putting in the correct password. When I log into PHPMyAdmin it the _users password table is in bcrypt successfully. What's wrong here?

Site: http://wickedbb.com

I would really, really appreciate some help. I love MyBB and your support is terrific.
Reply
#2
Solved: 5 Years, 1 Month, 4 Weeks ago
I wrote that tutorial, the salt should say Bcrypt if done successfully. Are you sure all of the file edits are correct?

Edit: I somehow completely forgot to add a file edit, I have edited the tutorial.
Reply
#3
Solved: 5 Years, 1 Month, 4 Weeks ago
(2016-03-16, 12:41 AM)Boonie Wrote: I wrote that tutorial, the salt should say Bcrypt if done successfully. Are you sure all of the file edits are correct?

Edit: I somehow completely forgot to add a file edit, I have edited the tutorial.

Yeah the first UID Salt says BCrypt.

Can you help me out? I did everything so far in your tutorial, but then I replaced the files with mybb default files. Now I'm kind of in a position I don't know what to do.

Sad

I will pay if someone can help me fix this issue.
Reply
#4
Solved: 5 Years, 1 Month, 4 Weeks ago
It should work if you followed the tutorial and didn't make any mistakes, I have been using this on my test forum for a while. You should have made a database backup like I said at the start of the tutorial. You can just re-import it and replace all of the files you edited.

I have replied to your PM either way.
Reply
#5
Solved: 5 Years, 1 Month, 4 Weeks ago
(2016-03-16, 11:07 AM)Boonie Wrote: It should work if you followed the tutorial and didn't make any mistakes, I have been using this on my test forum for a while. You should have made a database backup like I said at the start of the tutorial. You can just re-import it and replace all of the files you edited.

I have replied to your PM either way.

I made a backup and none of my files have been hurt Smile

Still not sure what the issue was though.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)