Not Solved Can't access certain templates (403 forbidden)
Not Solved
hey, been working on my forum for a while. it's over here at as you can see, it's also totally broken.

yesterday, i tried to log into my forum on someone else's laptop. however, upon getting into admin CP, i couldn't edit certain templates, like the header or footer. others i could change, as well as the stylesheet, but i absolutely can't modify the header. i thought maybe reverting the code and then replacing it with my customized version again would fix the problem, but unfortunately, i just totally lost the header code since i did all that work on someone else's laptop.

upon logging into cpanel to see if there was a permissions issue (despite the fact that i don't remember changing any permissions since the last time i could access the templates) i got some sort of block that mentioned unusual activity from the IP i was on, and prompted a captcha before i could log in again. i could get into cpanel after that, but i never could edit the templates, so i gave up and logged out of everything (i never save PWs on pcs, also).

today, i tried once again to log in to do some work on my forum (thru the forums, not cpanel) and encountered the same issue. it seems i can sometimes make minor edits to my templates, but i can never fully replace the code i had before that was necessary for the entire site to run. everything is very unpredictable. upon trying cpanel i encountered the same issue again, with the "unusual activity" warning and the captcha.

i am worried i am somehow blocked because of this "unusual activity" which is worrying because all the scans i have run (avast, then malwarebytes) came up clean for my pc. i'm not an avid torrenter or anything; the fact that it took me a week to download filezilla to transfer plugin files to my WIP forum because i was so paranoid should be a good indicator of how little i stray from trusted sites at this point in my life and how little i download anything besides flickr images. i do, however, know that one other person i live with (the same person whose laptop i borrowed when on the trip away from home) does download some more sketchy stuff sometimes, and so if it's possible mybb is blocking me because of my shared IP with them... i guess i'll ride them harder to keep their PC clean.

BUT if i've just somehow forgotten to get my permissions correct, i want to get that sorted out. i have cache/themes set to 775, and i've experimented with making each individual file 775, but it didn't change anything, so i switched them back.

this was never an issue before yesterday in the... month lol i've been using mybb, everything has been smooth. any clue what could be the culprit & if this is a permissions issue?

also, forgot to mention, the edit UI (with the line counter) has also completely vanished and my code is in plain text, as seen here.
Not Solved
looks like mod_security is affecting. see related guidance (also applicable for MyBB 1.8.x)

if you have access to mod_security at your web host panel then it might be better to turn it off.
if you do not have the access then contact your web host support.
Not Solved
ok, good to know. if, hypothetically, the other person in the house *does* have some sort of virus sending out weird queries and triggering the threat message (which i'm concerned about because this person does get viruses relatively frequently), is it safe to turn off modsecurity while we share a network? it isn't listed as installed in the PHP info, & i've already changed the htaccess file into an active one. just wanted to make sure before i possibly contact the host about it.
Not Solved
I had a similar issue after changing some firewall settings in .htacess:
Not Solved
i've gotten in contact with my web host who's instructed me to use a code to disable mod_security, but it hasn't helped. disabling it in public_html doesn't do anything, either. to be fair, i can't have my host just completely disable modsecurity from their end, because i'm in a shared server, but i should be able to disable it from my files as well. i've even replaced htaccess with the default installation one, and my web host has whitelisted my ip, but i still can't edit any templates without a 403 warning.

i also haven't changed any firewall settings, and other site scripts work just fine. my web host support says it looks like something in the admin area is triggering the 403 errors.

any ideas?
Not Solved

as i said, i've contacted my web admin who has whitelisted my IP. he cannot disable modsecurity from their end because i'm on shared hosting, but adding a disabling code does nothing to fix the issue in either the public_html or my subdomain mybb board.

ramnode (my host) has even whitelisted my IP, and nothing has changed. i can't make real changes to my template codes without a 403 error upon trying to save, no matter what device i use (i've tried on my phone and another laptop on my network, and have tried accessing it from another location/network.)

at this point i'm considering just totally uninstalling and re-installing mybb, but i've already done that once before, and it was very messy. should i go to the admin support section of the forum so someone else can replicate the problem and go from there? i haven't been able to access my forum in 6 days, and i'm paying for it to stay up, so i really need to figure out how to fix this. thank you.

i decided to just re-install mybb and restore all the tables. it works fine now. i don't know what the problem was, sorry to anyone reading this in the future from google--just re-install it. the issue was clearly something in my installation files, since the actual database was fine--hence it coming up clean in verification checks, etc. perhaps i accidentally bumped some sort of security option when installing a modification or something. thank you both people who tried to help!

Forum Jump:

Users browsing this thread: 1 Guest(s)