Not Solved [Error Message] Error 1045 ([email protected] Password:yes) After an sql table update!
Not Solved
Hi, I must apologize if I cannot provide all the info as I don't have access to it all at the moment.

Im posting regarding a client of mine that uses your platform and I was tasked with making some fixes to a table on the MySQL Database.

So what happened was after he migrated to MyBB his messages had some leftover syntax with the links and also some javascript code in there too that he wanted removed on over 30000 posts (out of 65000 total) so I built a couple of queries to handle simple replacements of some strings and then I built a function to handle the various links code which had various tags and varied quite a lot...

The function seemed to work fine and did what I needed it to do, I called it via a query... I discovered that my client didn't really know what he was doing with anything so I ran the update for him on the database using some credentials he gave me, these credentials where not root level nor did I have access to much accept table updates just saying just in case this caused the problem....

so the actual problem was after the update the website was inaccessible, the Error 1045 and a little bit of information saying the [email protected]ost or password was incorrect!!??

I know that this requires I go over the user file and check everything but my question is....

Why would a simple table update on the Database cause this platform to completely fail.

Additional notes, a restore on the database immediately fixed the problem, but the messages are now still mixed with all the html, javascript etc and my client isn't happy.
Not Solved
See here as to why Error 1045 occurs. I haven't experienced this (nor should it) when messing around with the database.
Plugin Count: I lost count.
Public Plugins are available here.
Please do not PM me for support unless asked to.
Not Solved
Yes I have been through this documentation but ty for the reply...…

i dont believe even a corrupted table from an update could cause this problem. but i am ultimately being blamed for it which is part of the job i guess......

but i am very eager to find out what exactly is happening here.....

Is it possible that someone updating the database with some modified or lacking rights could cause the table to change as far as rights are concerned?

Forum Jump:

Users browsing this thread: 1 Guest(s)