Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Internal Server Error on first page
#4
Not Solved
I tried that before and it just hung on the next line. Although I tried again and got it to print through print_header and the next few lines, but only if I told it to exit afterwards. Trying to get it to print_footer but it seems to be hanging. Almost like the server keeps getting to points where it can't handle everything in memory... is 1GB memory low for this? It's just our test box but I'd like to run it successfully before putting it on our live server. For now I guess I'll try commenting out some more stuff to see if I can coax it some more.

OK, I think I figured it out. I forgot that after I installed the forum, I limited the DB permissions on the server for the DB user to Select/Insert/Update/Delete/Execute to see if the forum would work clamped down like that (didn't see any documentation on necessary permissions, but I confess I didn't look that hard). But I forgot I still needed to merge... looking at the debug class I see that it tries to create tables for debugging, but it didn't have permission to do that. So I think that's what was causing it to hang. I restored the permissions and reloaded all the files and it looks like it's working. I'll post again once it completes. Thanks.

Completed successfully. Should I submit a bug report about the script hanging if it tries to create a table when it doesn't have permission? Or is that not worth it since I basically caused it myself? What is the minimum permissions needed for the database anyway? Thanks for helping me point myself in the right direction.


Messages In This Thread
RE: Internal Server Error on first page - by jhfitness - 2012-11-02, 06:02 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)