Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [Mail] Activation Email Problem
#5
Not Solved
excuse me for up this topic.i cant find the code:
mail($to, $subject, $message, $headers);
in functions.php
but find this:
function my_mail($to, $subject, $message, $from="", $charset="", $headers="", $keep_alive=false, $format="text", $message_text="", $return_email="")
{
	global $mybb;
	static $mail;
	
	// Does our object not exist? Create it
	if(!is_object($mail))
	{
		require_once MYBB_ROOT."inc/class_mailhandler.php";
		
		if($mybb->settings['mail_handler'] == 'smtp')
		{
			require_once MYBB_ROOT."inc/mailhandlers/smtp.php";
			$mail = new SmtpMail();
		}
		else
		{
			require_once MYBB_ROOT."inc/mailhandlers/php.php";
			$mail = new PhpMail();
		}
	}
	
	// Using SMTP based mail
	if($mybb->settings['mail_handler'] == 'smtp')
	{
		if($keep_alive == true)
		{
			$mail->keep_alive = true;
		}
	}
	
	// Using PHP based mail()
	else
	{
		if($mybb->settings['mail_parameters'] != '')
		{
			$mail->additional_parameters = $mybb->settings['mail_parameters'];
		}
	}
	
	// Build and send
	$mail->build_message($to, $subject, $message, $from, $charset, $headers, $format, $message_text, $return_email);
	return $mail->send();
}

this was different with doc.
plz help me for solve this.

additional: test mail in doc work correctly.without delay and lag.


Messages In This Thread
Activation Email Problem - by Fahadking07 - 2014-06-28, 08:18 PM
Activation Email Problem - by dragonexpert - 2014-06-28, 09:27 PM
RE: Activation Email Problem - by ArchPrime - 2014-07-01, 08:57 AM
RE: Activation Email Problem - by Sazze - 2014-07-01, 04:20 PM
RE: Activation Email Problem - by firstboy000 - 2014-08-29, 12:02 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)