Jump to the post that solved this thread.
Not Solved missing tables causing merge failure
Not Solved
I just put a clean install of Mybb on my server and I want to merge an older forum into it. I keep getting an SQL error preventing me from going to the index page of the merger to begin the process.

MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1146 - Table 'c2_kitchen.mybb_debuglogs' doesn't exist
    INSERT INTO mybb_debuglogs (`type`,`message`,`timestamp`) VALUES (4,'File: /merge/index.php Line: 51 Function: Log->trace0 -> \r\nMyBB Merge System Started: $version_code: 1806 $merge_version: 1.8.6',1447349936) 

Please contact the MyBB Group for technical support.

Mybb version 1.8.6
merger version 1806

I don't know how to fix this.
I reinstalled a clean copy of Mybb 1.8* 3 times in hopes this fixes the issue but it does not.


Something is wrong with the 1806 install.
The board as itself works fine but when you try to merge it does not.

I uninstalled the 1806 files and installed a clean 1805
I uploaded the 1805 merge file
I start the merger process again and it's fine except it will not move forward until I upload the 1806 merge. Fine. Did that.

When I get to the page where it asks me which forum software I want to merge FROM Mybb 1.6* is NOT on the list but 1.8* is. I select that anyway and plug away.

When the system gets to the import avatars it craps out saying permissions on the directory are wrong and can't be read. Permissions are fine but I temporarily put them to 777 anyway.

Still won't work so I skip to the uploads import. Same thing as above.
I go back and for the heck of it I try avatars again. Seems to be moving now except I have to hit "next" to progress as it won't do it on it's own despite the big red bar on the page.

Same thing for the uploads. I have to keep hitting next.

Merge finishes and I go to the ACP and do the cleaning up and rebuilding necessary.

All looks good except that the images are not showing in the posts as they were. They are all now downloadable links that cannot be viewed as the error says the Image contains errors. Not sure how to correct this.

Need to sort this stuff out so I can take the site live.
Jump to the post that solved this thread.

Messages In This Thread
missing tables causing merge failure - by Goggalor - 2015-11-12, 05:47 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)