Not Solved [General] Email notifications not working for new PMs
#1
Not Solved
Right now I am making a forum and testing everything, and notification emails for new pms are not sent. 

Email Settings are configured properly, other emails (like registration and user-to-user emails) are working fine, and I see them in the User Email Log. 
Nothing shows in the System Email Log hence nothing has failed.  

The test user I am sending the private message to has the checkbox "Notify me by email when I receive a new Private Message." checked. 

This user's email address is one from Mail-tester.com and I sent 3 PMs in the last 3 hours and so far no more email showed up in mail-tester.com except the first ones I tested which were Account activation and User-to-user emails, which worked fine and with good scores. 


The test user is not logged in (in case it does not send the notification if he is logged in, which I don't know if this is really how it works). 

It would seem like MyBB simply does not even try sending a notification email, just like if the checkbox for receiving these was not checked for the test user. 

The first PM was sent almost 3 hours ago, is it because there is a time at which these notification emails are sent and that I simply did not wait long enough ? If so, can I change this so the notifications are sent every hour ?

Thanks a lot for the help !
Reply


Messages In This Thread
Email notifications not working for new PMs - by farimah - 2017-12-27, 01:45 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)