Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [Security] Awaiting Registration permissions not working
#9
Not Solved
I won't be sure but I think it could only be loading forum permissions for groups which actually have custom forum permissions set and not "root" ones if that makes sense.

Since there were custom permissions for the awaiting activation they were displayed. But guests probably don't have custom permissions hence they display nothing.

Quote:How come the forum permissions override the user permissions? I think that's very wrong and makes no sense.

Quote:Seems some of them had actually created and posted in the forum, while the permissions say they cannot create anything there.

Posting isn't a per user base but a per group base permission (to clarify) (edit: i think they actually are). It was simply decided that forum permission to take priority upon group permissions.

I actually think if they were the other way it would cause the permission system to be more complicated than it is. I think that is how phpBB, xenForo, and vBulletin do it as well.

Quote:but since they don't receive the email either...

Do they never receive it? Either way I think you should probably check your server. I don't recall any current known issue with the mass mail queue system.
Reply
Jump to the post that solved this thread.


Messages In This Thread
RE: Awaiting Registration permissions not working - by Omar G. - 05-08-2018, 04:42 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)