Jump to the post that solved this thread.
Not Solved Signature not showing in some threads?
#7
Not Solved
(2020-04-21, 08:56 AM).m. Wrote: change signature option at user control panel should be having below options
 Enable my signature in all of my existing posts.
 Disable my signature in all of my existing posts.
 No action.
if first option is selected then that would apply for all existing posts
existing signature can be saved again with the option enabled.

related template : usercp_editsig [in user control panel templates]
related code from MyBB Stock Theme :
<span class="smalltext">
<label><input type="radio" class="radio" name="updateposts" value="enable" />&nbsp;{$lang->enable_sig_posts}</label><br />
<label><input type="radio" class="radio" name="updateposts" value="disable" />&nbsp;{$lang->disable_sig_posts}</label><br />
<label><input type="radio" class="radio" name="updateposts" value="0" checked="checked" />&nbsp;{$lang->leave_sig_settings}</label></span>

SQL queries (for all users)
UPDATE `mybb_users` SET `showsigs` = '1' WHERE `showsigs` = '0';
UPDATE `mybb_posts` SET `includesig` = '1' WHERE `includesig` = '0';

SQL queries for a single user
UPDATE `mybb_users` SET `showsigs` = '1' WHERE `uid` = 'x';
UPDATE `mybb_posts` SET `includesig` = '1' WHERE `uid` = 'x';

Everything is fixed and as it should now. Thanks!
Reply
Jump to the post that solved this thread.


Messages In This Thread
RE: Signature not showing in some threads? - by makpaolo - 2020-04-21, 09:01 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)