Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] Admincp IPaddress query problem
#1
$query = $db->simple_select("posts", "DISTINCT ipaddress,pid", "uid='{$mybb->input['uid']}'");


That's the query from /admin/modules/user/users.php on line 1398 (at least of the new file I have).

The problem is that this repeats IPs and actually make a pretty big query result if a member has thousands of posts and actually choked my large forum. The pid from DISTINCT should be removed as it's not needed for this query.

$query = $db->simple_select("posts", "DISTINCT ipaddress", "uid='{$mybb->input['uid']}'");

My tests show this as working perfectly well but of course dev team should confirm.

Oh...a couple lines down I see where the pid is used to create the unique identifier for the popup. You can substitute it with the IP address though.

$popup = new PopupMenu("post_{$ip['ipaddress']}", $lang->options);

Again..seems to be working perfectly fine under my tests.

Thanks and I hope this gets added to next release.

Since I have 1.4x on hackforums.net now I am finding lots of things that could use improvement. It's a big site and requires a lot of admincp moderation. So far mybb 1.4x is doing well overall but certain parts are slow or clunky. I will help with fixes and suggestions as best I can.

Thanks.


Messages In This Thread
[F] Admincp IPaddress query problem - by labrocca - 10-22-2008, 01:10 AM
RE: Admincp IPaddress query problem - by labrocca - 10-22-2008, 04:17 AM
RE: Admincp IPaddress query problem - by labrocca - 10-22-2008, 05:30 AM
RE: Admincp IPaddress query problem - by labrocca - 10-24-2008, 11:32 PM
RE: Admincp IPaddress query problem - by labrocca - 10-29-2008, 03:04 AM
RE: Admincp IPaddress query problem - by labrocca - 10-29-2008, 03:35 PM
RE: Admincp IPaddress query problem - by labrocca - 10-29-2008, 04:47 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)