Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] Database Importing Problem
#1
Hi, while trying to import my old database in to a new copy of myBB. I am unable to do so and receive some error. This make no sense, I backup the database 10 mins before trying to restore it ON THE SAME SERVER. Can anyone help me out or I am in deep sh*t.

Error I have receive.

Quote:SQL query:

-- MyBB Database Backup
-- Generated: 10th December 2006 at 09:57
------------------------------------- --
CREATE TABLE mybb_adminlog (
uid int( 10 ) unsigned NOT NULL default '0',
dateline bigint( 30 ) NOT NULL default '0',
scriptname varchar( 50 ) NOT NULL default '',
action varchar( 50 ) NOT NULL default '',
querystring varchar( 150 ) NOT NULL default '',
ipaddress varchar( 50 ) NOT NULL default '',
KEY scriptname ( scriptname , action )
) ENGINE = MYISAM DEFAULT CHARSET = latin1;

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '---------------------------------------

CREATE TABLE mybb_adminlog (
uid ' at line 1
#2
What version of mysql are you running? If the table already exists, you can just remove the "create table" part, i guess. I don't see anything wrong with the sql, but i could be wrong.
#3
I am running on MYSQL 4.1.10. I tried removing all the table inside that database and import in again. But seem to still get the same error.
#4
i have the same problem and the table doesnt exists Sad
#5
Simply delete these lines from above of your sql file:
-- MyBB Database Backup
-- Generated: 22nd January 2007 at 08:20
---------------------------------------
Good Luck! Smile
(Original Source of this solution)
#6
This bug has been fixed in the latest code.

Please note the latest code is not live on the site or for download. An update will be released which contains this fix.
#7
Use the following file to fix:


Attached Files
.php   dbtools.php (Size: 13.93 KB / Downloads: 352)


Forum Jump:


Users browsing this thread: 1 Guest(s)