Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] Board style missing
#1
I have two style in my board that can be used by members. The first one is MyBB Default, the second one is Style A. When using User CP > Edit Option > Board Style, I just see the Use Default and MyBB Default without Style A. I can't use Style A until I set it as default style on ACP and select Use Default in User CP.

Also I have another forum with 6 styles installed there (say there are MyBB Default, Style A, Style B, Style C, Style D and Style E). From User CP, I can select MyBB Default, Style A until Style D, but no Style E. However I can see the Style E out of Board Style select box.

Here is the HTML code of the forum with 5 styles installed that seems wrong:
<select name="style"><option value="0">Use Default</option>
<option value="0">-----------</option>
<option value="7">Style A</option>
<option value="4">Style B</option>
<option value="2" selected="selected">MyBB Default</option>
<option value="5">Style C</option>
<option value="6">--Style D</option></select>
<option value="3">Style E</option></select>
#2
Can you edit the theme Style A and make sure that the "All Usergroups" checkbox is selected in the list of usergroups?

Can you post a link to the forum so that we can take a look?

Thanks.
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#3
The problem with the forum with 2 styles has been solved. I forgot to check "All Usergroups".Shy

However the second forum with 6 styles still has the problem.
http://forum.smabhk.com

Looks like the problem come if I add a new theme and it is a child of other theme. For example, if I have Style A as the parent theme with Style B as the child theme, then the problem will happen. However if I removed the Style B, the problem disappear.
#4
Hi.

If you wish to fix it yourself, please open up inc/functions.php and find:
	if($tid)
	{
		$themeselect .= "</select>";
	}

Replace it with:
	if($tid == 0)
	{
		$themeselect .= "</select>";
	}

Chris
#5
This bug has been fixed in the latest code.

Please note the latest code is not live on the site or for download. An update will be released which contains this fix.


Forum Jump:


Users browsing this thread: 1 Guest(s)