Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] mySQL error when splitting post from thread...
#1
I'm really not sure if this isa bug or not as I think I did manage to split a post from a thread before (but my memory fails me)

This is the mySQL error I receive when I try to split the post:

MySQLi error: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALL THIS PART HERE IS THE CONTENT)' at line 1
Query: INSERT INTO mybb_threads (fid, subject, icon, uid, username, dateline, lastpost, lastposter, replies, visible, notes) VALUES ('ALL THE VALUES HERE);

My host uses mySQL 5.0.x.x. Smile

Merging threads is fine... it's just the splitting posts.

Thanks in advance for any help!Big Grin
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
#2
Well we won't be able to figure it out until you say what is in the "ALL THIS PART HERE IS THE CONTENT" Can you repost the exact error, or PM it to me.

Also, what method did you use to split the post?
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#3
Hi Dennis,
Thanks for your reply Smile I've PM'd the full error details to you.

With regards to method, it's something I've always used:
1. Check the relevant post tickbox
2. Scroll to bottom of the post
3. Select 'Split Posts'
4. It gets to the 'set new thread title/location' page
5. I click submit, and the error pops up.

Thanks Big Grin
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
#4
Are you running MyBB 1.2.7?
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#5
I did run the upgrade a while back when it came out and the main admin info page says it's 1.2.7.
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
#6
Can you download MyBB 1.2.7 again and extract inc/class_moderation.php from the pacakage. Delete the existing inc/class_moderation.php from your server and reupload inc/class_moderation.php. See if that fixes your problem.
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#7
Sorry about the late reply. I've just tried to upload a new class_moderation.php but it still gives the same message. What I have noticed though is that the content in the first part *isn't* in fact the actual post I selected. Is this usual? As in, it says 'MejiX' but the last poster was a 'Faust'.

Thanks again Big Grin
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
#8
Can you try this inc/class_moderation.php file please and see if your problem is fixed. Try splitting the same posts.


Attached Files
.php   class_moderation.php (Size: 42.65 KB / Downloads: 246)
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#9
Hi DennisTT,
Thank you so much for your help! Big Grin It works perfectly now! ^^ WOW! Thanks again!
Hopefully it wasn't too much of a big thing to fix.
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
#10
* Dennis Tsang note to self to commit this to SVN
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net


Forum Jump:


Users browsing this thread: 1 Guest(s)