Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.8 Security update breaks the whole theme & customization
#4
The system isn't perfect, it is true.

When template changes are required as part of an update, this can cause issues for themes, and as you've discovered, break things. Unfortunately, this is unavoidable. We don't want to break your theme, but you must understand that sometimes it is necessary to update the templates and JavaScript.

Here are some tips to making all of this easier on yourself.

Install MAMP or some other local PHP-equipped host.

Use a backup of your forum to install an exact copy of your forum on your local system. (If you've never done this before, you may want to try just installing a new copy of MyBB 1.8.20 locally as practice.)

Now that you have a practice copy of your forum, perform the upgrade. Immediately after the upgrade, you will need to see the templates that were affected by the upgrade. You can find guidance on that part here (Read down a bit)

This is a very important step. To add to the info I linked, I'll give you my approach.

I get the diff report open in one tab and then edit the template in the other tab. As I figure out what parts I need to update, I make the edits and when I am done, I save the template and move on.

If you have issues on the local copy, then obviously you can do that much more easily on a local copy, rather than messing about with a live site.

If everything goes correctly, then you can feel good about performing the upgrade on your live forum.

I'm sorry you are having problems. Just trying to help.
[retired]
Reply


Messages In This Thread
RE: Security update breaks the whole theme & customization - by Wildcard - 2019-03-01, 03:36 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)