Jump to the post that solved this thread.
Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved SQL Error during install
#1
Not Solved
Hello!
I've been trying to install mybb 1.6.4 on a server for a few hours now and I always get the same SQL error. I've search this forum, googled and yahooed and nothing I've found has been able to help. Thanks in advance for your help!

The server runs linux, PHP 5.2.10 and MySQL 4.1.22

Here's the error I get during the Table Creation step:

Quote:Database Engine: MySQLi 4.1.22

The MyBB database tables will now be created.
Creating table mybb_adminlog...done
Creating table mybb_adminoptions...done
Creating table mybb_adminsessions...done
Creating table mybb_adminviews...
MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'fields text NOT NULL, conditions text NOT NULL, custom_profile_fields text NOT' at line 7
Query:
CREATE TABLE mybb_adminviews ( vid int unsigned NOT NULL auto_increment, uid int unsigned NOT NULL default '0', title varchar(100) NOT NULL default '', type varchar(6) NOT NULL default '', visibility int(1) NOT NULL default '0', fields text NOT NULL, conditions text NOT NULL, custom_profile_fields text NOT NULL, sortby varchar(20) NOT NULL default '', sortorder varchar(4) NOT NULL default '', perpage int(4) NOT NULL default '0', view_type varchar(6) NOT NULL default '', PRIMARY KEY(vid) ) ENGINE=MyISAM CHARACTER SET utf8 COLLATE utf8_general_ci;

#2
Not Solved
Are all the files uploaded?
Please rep me if I helped you Smile
#3
Not Solved
Thanks for helping. I'm double checking.
What could be missing?

Edited: I've reuploaded all the files and started fresh. I'm am still getting the exact same error...
#4
Not Solved
You need MySQL 5.
No longer involved in the MyBB project.
#5
Not Solved
Thanks for the help!
#6
Not Solved
(2011-08-31, 04:53 PM)Malcolm. Wrote: You need MySQL 5.
No, MySQL 4.1 is still supported. This is just a bug: http://dev.mybb.com/issues/1676
[Image: banner.png]
#7
Not Solved
Honestly though, people shouldn't be using MySQL 4 these days, and if it's all your host offers then they suck and you should find a new one.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)