Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [Mail] More and more SMTP hassle
#11
Not Solved
*posted there*

(besides that: I'm not sure it's "the way it works" ... trying to send an email by [email protected] from the mail server yyy.com could be interpreted as an attempted abuse (which the error obviously points to), so it would rather be a fix than anything else.)
[Image: 350x19.jpg][Image: tstargermany.png]
#12
Not Solved
Yes, that's true. The way it currently works emails can be considered as spam, and I agree with the suggestion. Still, this is the way it was originally designed, and it's not technically a bug. Toungue
#13
Not Solved
Ok, I have a temporary workaround, taking THIS into consideration
(tonight, I've sent a massmail to all my users and got this error several times in the mail log. Luckily the <frombbname> isn't crucial to the fix.)

inc/class_mailhandler.php

starts at line 261

original
		// Build mail headers
		if(!trim($this->from))
		{
			if($mybb->settings['mail_handler'] == 'smtp')
			{
				$this->from = $mybb->settings['adminemail'];
			}
			else
			{
				$this->from = '"'.$this->utf8_encode($mybb->settings['bbname']).'"';
				$this->from .= " <{$mybb->settings['adminemail']}>";
			}
		}

		$this->headers .= "From: {$this->from}{$this->delimiter}";
		
		if($this->return_email)
		{
			$this->headers .= "Return-Path: {$this->return_email}{$this->delimiter}";
			$this->headers .= "Reply-To: {$this->return_email}{$this->delimiter}";
		}
		elseif($mybb->settings['returnemail'])
		{
			$this->headers .= "Return-Path: {$mybb->settings['returnemail']}{$this->delimiter}";
			$this->headers .= "Reply-To: {$mybb->settings['adminemail']}{$this->delimiter}";
		}
		else
		{
			$this->headers .= "Return-Path: {$mybb->settings['adminemail']}{$this->delimiter}";
			$this->headers .= "Reply-To: {$mybb->settings['adminemail']}{$this->delimiter}";
		}

workaround
		// Build mail headers
		if ($mybb->settings['returnemail'])
		{
			if($mybb->settings['mail_handler'] == 'smtp')
			{
				$this->from = $mybb->settings['returnemail'];
			}
			else
			{
				$this->from = '"'.$this->utf8_encode($mybb->settings['bbname']).'"';
				$this->from .= " <{$mybb->settings['returnemail']}>";
			}
		
		}
		else
		{
			if($mybb->settings['mail_handler'] == 'smtp')
			{
				$this->from = $mybb->settings['adminemail'];
			}
			else
			{
				$this->from = '"'.$this->utf8_encode($mybb->settings['bbname']).'"';
				$this->from .= " <{$mybb->settings['adminemail']}>";
			}
		}
		$this->headers .= "From: {$this->from}{$this->delimiter}";
	
		if($this->return_email)
		{
			$this->headers .= "Return-Path: {$this->return_email}{$this->delimiter}";
			$this->headers .= "Reply-To: \"User ({$this->utf8_encode($mybb->settings['bbname'])})\" <{$this->return_email}>{$this->delimiter}";
		}
		elseif($mybb->settings['returnemail'])
		{
			$this->headers .= "Return-Path: {$mybb->settings['returnemail']}{$this->delimiter}";
			$this->headers .= "Reply-To: \"Email from {$this->utf8_encode($mybb->settings['bbname'])}\" <{$mybb->settings['adminemail']}>{$this->delimiter}";
		}
		else
		{
			$this->headers .= "Return-Path: {$mybb->settings['adminemail']}{$this->delimiter}";
			$this->headers .= "Reply-To: \"Email from {$this->utf8_encode($mybb->settings['bbname'])}\" <{$mybb->settings['adminemail']}>{$this->delimiter}";
		}
Because of the other related error (see link at the top), the mybbname wasn't inserted as the NAME for the FROM email adress, but that's ok i guess.

Btw: The extra "RETURN-PATH" arguments are largely ignored by the server and instead taken from the FROM values < Just to mention it.
[Image: 350x19.jpg][Image: tstargermany.png]
#14
Not Solved
I'm trying to send mail by setting it to our members ....
Using script mybb
But e-mail seems to be gone .. But, unfortunately, no e-mail address does not reach the ...

I wonder ... I opened my gmail account, saying demi error mybb
I tried doing the smtp settings ..
Yollayabiliyorum from Gmail!
We would appreciate it if you help please.
php mail telling natro.com çaılşmıyor already disabled
forced to use the smtp smtp asp is working on my site, but
The only problem I can not run the SMF MyBB MyBB grandfather had worked
How do I fix the most simple way
help please


Forum Jump:


Users browsing this thread: 1 Guest(s)