Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 10 Years, 4 Months, 2 Weeks ago Fresh Install - SQL Error
#1
Solved: 10 Years, 4 Months, 2 Weeks ago
I got partway through the installation process, then ran into the following error. My ISP uses an old version of MySQL but I did modify the file ./inc/db_mysql.php, as required.

The installation wizard was going along fine, until this:

Connection to the database server and table you specified was successful.

Database Engine: MySQL 4.0.27

The MyBB database tables will now be created.
Creating table mybb_adminlog...done
Creating table mybb_adminoptions...done
Creating table mybb_adminsessions...done
Creating table mybb_adminviews...
MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'fields text NOT NULL, conditions text NOT NULL, custom_profil
Query:
CREATE TABLE mybb_adminviews ( vid int unsigned NOT NULL auto_increment, uid int unsigned NOT NULL default '0', title varchar(100) NOT NULL default '', type varchar(6) NOT NULL default '', visibility int(1) NOT NULL default '0', fields text NOT NULL, conditions text NOT NULL, custom_profile_fields text NOT NULL, sortby varchar(20) NOT NULL default '', sortorder varchar(4) NOT NULL default '', perpage int(4) NOT NULL default '0', view_type varchar(6) NOT NULL default '', PRIMARY KEY(vid) ) ENGINE=MyISAM;
#2
Solved: 10 Years, 4 Months, 2 Weeks ago
MySQL 4 is way too old. As stated in the Wiki, that is just a workaround - not an alternative. You should really switch web hosts. Don't even ask your web host to upgrade MySQL. If they didn't bother upgrading their software then you shouldn't bother wasting their time with them either.

And it's not just the installation. You will most certainly run into more of these errors. MySQL 4 is not reliable.
#3
Solved: 10 Years, 4 Months, 2 Weeks ago
Thank you. I agree 100% with your comment. The problem is that I am doing this install for a charity on their site and this is the host they are using. I guess in light of this situation myBB is not going to be a possibility as long as this hosting company is being used. Again, thanks for your quick response. Smile
#4
Solved: 10 Years, 4 Months, 2 Weeks ago
I understand that. But I doubt it any other forum software fully supports it. It's not that MyBB is incompatible with it or anything, MySQL 4 has just reached its end of life cycle and is not supported by their developers. With the release of MySQL 5, MyBB moved on and updated their code to be more efficient and up to date - thus not working with MySQL 4.

Do the charity organization a favour and pursue them into switching web hosts. Who are they hosted with and how much are they paying? The price doesn't really matter really, because whatever they're paying is a rip-off considering the company can't keep up to the latest software. I would be more than happy to recommend you a better, cheaper web hosting company and assist you with the installation shall you encounter any issues.

You should also send them an email saying shame on them for ripping off a charity organization. That should be a crime. (j/k Toungue)
#5
Solved: 10 Years, 4 Months, 2 Weeks ago
What you suggest is true; their ISP doesn't deserve the charity's business, and they probably do pay too much. There are a number of ways to proceed from here, and I do know at least one good Canadian ISP (the one I use for my personal stuff) but of course all such discussion at this point is beyond the scope of this technical support forum, so I think this will be my last post in this thread, and thanks again.
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)