Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [Performance] Task Not Working
#1
Not Solved
Right I set the rssfeedposter task to run every minute of every hour of every day of every month and it seems to do it like every so often with huge gaps inbetween, now the feed I run updates very fast and I can't make the how many it posts at a time any bigger so I need the task to run more often but it doesnt work.
#2
Not Solved
You can use cron instead. The wiki states on how to do that.
No longer involved in the MyBB project.
#3
Not Solved
I get the first bit for creating the shell script, but where does the cron bit go?
#4
Not Solved
If you use cPanel, the set the command to:

php /home/user/public_html/task.php x 

and change the settings to run every minute.
No longer involved in the MyBB project.
#5
Not Solved


cmod +x ~/forum_backup.sh
crontab -e
# in the crontab editor, enter a CRON expression like:
0 4 * * * ~/forum_backup.sh # run the backup every day at 4am

So I added this to task.php

Now how would I turn this: 0 4 * * * which makes it run every day at 4am, to every minute?
#6
Not Solved
Simply change it to * * * * *.
No longer involved in the MyBB project.
#7
Not Solved
Thanks Big Grin

Is everything right, I added:
 cmod +x /rssfeedposter.sh
 crontab -e
 # in the crontab editor, enter a CRON expression like:
* * * * * ~/rssfeedposter.sh  # run the backup every day at 4am
To task.php

And created rssfeedposter.sh with this in it:
now=`date +%Y-%m-%dT%H-%M` ; mysqldump -u ******* --password=*********** --skip-opt --add-drop-table --complete-insert --create-options --disable-keys=FALSE --extended-insert=FALSE --lock-tables --skip-set-charset --skip-comments --dump-date *************** > $now.sql ; zip -m $now.zip $now.sql

Thanks Again
#8
Not Solved
Huh? You can't run bash commands like that. To do that you need access to the server.

Plus the commands you've written down will backup a MySQL database, not run the feed poster.
No longer involved in the MyBB project.
#9
Not Solved
Huh I've followed the instructions and that's the end result. What have I done wrong? What do I need to do?

Edit: it seems to run, it is doing what it says, it's posting the feeds.
Ah forget that it doesnt work, the task happened to work for once reight after I'd added this but now it hasnt worked :X
#10
Not Solved
Ah forget that it doesnt work, the task happened to work for once right after I'd added this but now it hasnt worked :X


Forum Jump:


Users browsing this thread: 1 Guest(s)