Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mail doesn't work & bots gets through reCaptcha II and III
#1
Hi.

So the first issue..
Sending mail through phpmail have not been successful.
MyBB doesn't output an error, and reports that "the mail has been sent", but it hasn't. Using the example code found on mybb.com to test phpmail, written into a php file, the mail was generated and sent as expected.

Second issue.
There's several spam-bots coming through the registration process and registering on my fresh website everyday (telling me there would probably be hundreds of them if my site was more popular).
The 'Akismet' plugin is setup and activated, and so is reCaptcha II, and I've also tried reCaptcha III.
I never actually tried the standard Captcha that came with myBB, but I remember that bots easily got through phpBB's standard Captcha system, so I'm assuming that it's probably the same thing here.
Alternative: is there a plugin available for simple anti-bot-functions, for example custom questions? Smile
I tried searching and browsing for it, but didn't find one yet.

I don't know if it's relevant, but here's my website.
Thanks.
#2
to prevent bots, use registration security question plugin . see also responses here

#3
(2011-12-12, 03:30 AM)ranjani Wrote: to prevent bots, use registration security question plugin . see also responses here

Thanks, but the first plugin you link to seem outdated (not compatible with myBB 1.6.5), but I'll take a look at the rest.
Edit: those plugins seem badass! Like the stopforumspam.com plugin!

But I still don't know how to fix the problem with sending mail Sad
#4
if a plugin is not working in myBB 1.6.5 AND if it was working in earlier versions of myBB then see
* Plugin Changes coming in 1.6.5
* Script to Update Plugins for 1.6.5

for the mail issue, check System Mail Log at tools & maintenance section of admin panel
#5
(2011-12-12, 06:12 AM)ranjani Wrote: if a plugin is not working in myBB 1.6.5 AND if it was working in earlier versions of myBB then see
* Plugin Changes coming in 1.6.5
* Script to Update Plugins for 1.6.5

for the mail issue, check System Mail Log at tools & maintenance section of admin panel

Thank you.

Sorry for not checking the system mail log out myself.
And here we go, the error is:
Quote:MyBB was unable to send the email using the PHP mail() function.
Not like that's a very descriptive error, butBig Grin

I'll try setting up a SMTP server.
#6
Sfs is quite handy
#7
This user has been denied support. This user has been denied support.
(2011-12-12, 06:18 AM)Viqing Wrote:
Quote:MyBB was unable to send the email using the PHP mail() function.
Not like that's a very descriptive error, butBig Grin

I'll try setting up a SMTP server.
Your host might have disabled php send mail function, try contacting him.

#8
(2011-12-12, 09:09 AM)crazy4cs Wrote:
(2011-12-12, 06:18 AM)Viqing Wrote:
Quote:MyBB was unable to send the email using the PHP mail() function.
Not like that's a very descriptive error, butBig Grin

I'll try setting up a SMTP server.
Your host might have disabled php send mail function, try contacting him.

It's a VPS, so I've got root access.
PHP sendmail seem to be activated by the PHP configuration, and like I said earlier it works with the mybb.com example code found here :o.
Just doesn't work for myBB... Toungue

@Tankey
Yes, that's the only plugin I've installed so far after Ranji's link to a somewhat similar thread about my (spambot-) issue.
It sure is/seem great! Smile
#9
This user has been denied support. This user has been denied support.
Registration question is for sure best. I don't use email verification as well and so far no bots except human signups at very rare times.
#10
http://mods.mybb.com/view/stopforumspam-com-for-mybb i use this .
Its very good u check once.


Forum Jump:


Users browsing this thread: 1 Guest(s)