Not Solved 1.2 Troubles...
#1
Not Solved
So... I've switched over to 1.2, made myself a new theme and I can't get it to work.

I'm prolly just doing something wrong or not looking in the right place but I set the new theme as default and it wont overide the mybb theme. It labels it '(Default)' but... it doesn't change anything and the numbers of users with the mybb theme on stays there.

Any help would be great!

Thanks in advance...

-A
Reply
#2
Not Solved
The problem is that the MyBB Default Theme is stored in the users table for each user's default theme. You can run the following query to set your theme as the default theme for all users:
UPDATE mybb_users SET style = 'x';
Replace x with the ID of your theme. You can see the ID in the database table mybb_themes.
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
Reply
#3
Not Solved
You should do:
UPDATE mybb_users SET style=0;
As 0 is default theme. So if you change again the users will change aswell.
Reply
#4
Not Solved
ah yes, thats fixed it. Thanks muchly!

So would this be a bug?
Reply
#5
Not Solved
CraKteR Wrote:You should do:
UPDATE mybb_users SET style=0;
As 0 is default theme. So if you change again the users will change aswell.

Same problem here. How would I perform the above query?
Reply
#6
Not Solved
I figured it out. It's too bad you have to run a query each time you change the default theme.
Reply
#7
Not Solved
You can also set each forum individually to force a template. It's more cumbersome but when you change the sites default template it will change for all users. The problem is that if you do this you can't allow for multiple templates.

IMHO this should be changed in the next version.
Reply
#8
Not Solved
I've already reported this as an bug (not sure if it got fixed or not).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)