Thread Rating:
  • 53 Vote(s) - 3.98 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Login/Logout problems? PLEASE READ
#1
Not Solved
Recently, there have been a lot of people having problems logging in and/or logging out of their forums. This also includes having to login after every action in the ACP.

Almost every time, this is due to incorrect cookie settings. This is easy to fix, and here's how.

You can view your current cookie settings by viewing the source code from a page of your forum.

If your cookie settings are wrong, you probably won't be able to change them in the ACP as you may not be able to stay logged in. If this is the case, in order to change them, find a way to open and edit ./inc/settings.php (via FTP or a file manager) and edit the new values into the file. The settings you need to find/change in ./inc/settings.php are:

$settings['cookiedomain'] = ".example.com";
$settings['cookiepath'] = "/";
$settings['cookieprefix'] = "";


Then, you MUST go to 'ACP > Configuration > General Configuration' and make the change here too. This is because although editing the file will make you able to log in, the settings aren't updated in the database, and when you next save any settings in the ACP, the old settings will come back.
Also make sure ./inc/settings.php is CHMOD to 666.
Your cookie domain MUST NOT start with or contain http:// or https://!


If you are hosting on a localhost (i.e. a test forum on your computer), your cookie domain will usually have to be blank.

Also, if you have a port at the end of your board URL (for example, if your board URL is http://123.45.67.89:1234) set your cookie domain to .123.45.67.89 - basically remove the :xxxx from the end. If you have a directory at the end as well as a port (for example, if your board URL is http://123.45.67.89:1234/forum) set your cookie domain to .123.45.67.89 as above, and set your cookie path to /forum/ - the port number isn't needed anywhere.

If you cannot work out your cookie settings, you can use this cookie generator created by our very own DennisTT and it will attempt to give you the correct settings. It is also recommended that you do not change your cookie settings when you install your forum as they are usually correct in the installer.

99% of the time, this will solve the problem. However, sometimes your browser is set to not accept cookies, and this will cause a problem. Here's how to check your browser is accepting cookies:
  • IE 6/7/8 - Tools > Internet Options > Privacy (tab) > Change setting to 'Accept All Cookies' > Apply > OK.
  • FF3 - Tools > Options > Privacy (tab) > Cookies > Accept cookies from sites > *tick* > Accept third party cookies *tick* > keep until > *they expire* > OK.
  • Opera 9/10 - Tools > Preferences > Advanced (tab) > Cookies > Accept cookies > *tick*.
  • Safari - Edit > Preferences > Security (tab) > Accept cookies > Always > *tick*.
  • Chrome - Spanner symbol > Options > Under the Hood (tab) > Cookie settings > Allow all cookies.


After changing any cookie settings it may be necessary to clear your browser's cookies and then try again.

Still not working??

If you're sure the settings are right (i.e. they show what they should do in the source code of a page), settings.php is CHMOD to 666, and you've cleared your browser's cookies, try this.

Download a copy of ./inc/settings.php, and then delete it from your server. It should regenerate itself, and just in case it doesn't, you can reupload your downloaded copy. When it regenerates like it should (you may need to click around a few times on the forum to get it to regenerate), we'll know that it's a clean, fresh, uncorrupted version, with all the settings fresh from the database, meaning we'll be sure that the file is OK. Then, clear your cookies again, and try to login again.

----------------------------------------

If you are getting a white screen when you login and you have recently merged to MyBB, see here: http://community.mybboard.net/thread-420...#pid302288

----------------------------------------

If you are still having trouble, please tell us your URL. If you still have a problem but only say 'I still have a problem' but give no URL, we cannot help you in any way at all.
Before replying to this thread: clear your cookies in your browser and try one final time!

Also, if you are still having problems logging in or out, please post in this thread rather than making a new one, as there is often 2 or 3 threads on this each day.

Thank you Smile
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#2
Not Solved
Right, I just now downloaded mybb 1.6

I'm using WAMPserver, which is running Apache2.2.11, PHP5.3.1 and MySQL 5.1.36

I've gone through the documentation, did all things mentioned, like renaming the settings file, modifying security settings and such.

The install worked and I can now enter my admin panel.

The url is: http://localhost/mybb16/

However, during install, I set cookie domain to localhost. I later found that I should have left it blank.

I went to the settings.php file and edited it manually, so now it has this:

$settings['cookiedomain'] = "";
$settings['cookiepath'] = "/mybb16/";
$settings['cookieprefix'] = "";


But the admin panel still won't change. Everytime I edit something and click "save changes", it isn't saved, and I have to enter my credentials for each and every page load there is.
#3
Not Solved
Clear your cookies in your browser, if you changed it during install it'll still have those stored in your browser.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#4
Not Solved
That did the job, confirmed.
#5
Not Solved
I also wanted to state, that I randomly started having this problem in Chrome only, and deleted cookies, but later on realized it asks you from "how long ago." Be sure you tell Chrome far enough back that it will delete the right cookies. Smile
#6
Not Solved
This user has been denied support. This user has been denied support.
I'm having this problem, I did the 123.45.67.89 thing and that worked briefly but now I can't logout or use the Admin CP properly, help please
#7
Not Solved
(08-03-2010, 10:42 AM)MattRogowski Wrote: Clear your cookies in your browser, if you changed it during install it'll still have those stored in your browser.

I have cleared my cache, set to accept all cookies. It still won't save and still requires me to login each time.
#8
Not Solved
(08-09-2010, 10:07 AM)Jack123 Wrote: I'm having this problem, I did the 123.45.67.89 thing and that worked briefly but now I can't logout or use the Admin CP properly, help please

Clear cookies in your browser, your settings are fine.

(08-09-2010, 03:01 PM)kdr22 Wrote:
(08-03-2010, 10:42 AM)MattRogowski Wrote: Clear your cookies in your browser, if you changed it during install it'll still have those stored in your browser.

I have cleared my cache, set to accept all cookies. It still won't save and still requires me to login each time.

URL??
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#9
Not Solved
What are your cookie settings anyway?
No PM support
My YouTube
#10
Not Solved
(08-09-2010, 10:07 AM)Jack123 Wrote: I'm having this problem, I did the 123.45.67.89 thing and that worked briefly but now I can't logout or use the Admin CP properly, help please


You didn't really use "123.45.67.89" as your domain did you? 0.o


Forum Jump:


Users browsing this thread: 1 Guest(s)