Discuss: MyBB 1.2.1 Released
Chris Boulton Wrote:This isn't a support thread. If you have issues then you should post in the appropriate forum.

My appologies. I guess I didn't quite capture the purpose of this thread. Sorry.

That js file did fix my PM problem though. Thanks.
Just delete the settings.php file and it will recreate itself. However, the config.php file will need to be manually rebuilt.

ClarkF1 Wrote:Nice easy upgrade............

I decided to try the upgrade out first on the development server on my own PC.......accidentally overwrote settings.php and config.php

D'oh Big Grin

Made sure I took backups of them off the main site before uploading the files in case I forgot to exclude them.

CraKteR Wrote:Well the settings.php isn't really that important as you can make that from changing the settings.
However you need to write the config.php yourself. If you have another config.php you can just use that as an template. Smile
I just did the upgrade and hardly any images are working even though they are all uploaded

www.tastitunes.com

and if I try to log into to Admin I get

Warning: Cannot modify header information - headers already sent by (output started at /home/liskico/public_html/tastitunes/inc/languages/english.php:1) in /home/liskico/public_html/tastitunes/admin/global.php on line 93
Did you delete your "css" directory or replace its contents? The board cannot find the CSS for the theme you're using.

You need to go in to the Admin CP > Themes, go "Edit Theme Style" on the theme your using and then once that page loads click "Submit" so it rebuilds the CSS.
CraKteR Wrote:Copy your config.php and settings.php into the new directory and upgrade. However why would you want that? Don't you wanna upgrade the current board? As it would be the same as upgrading it in another directory. If you don't make an new database with the data though.

reason behind this is, i want to start a new board with out any plugins and additional themes installed but i dont want to loose my posts and user accounts.

the current board were my first shot at installing and maintaining a public board. starting a fresh new install will help me from now on to keep better track of what plugins and updates i have installed and what files i have done changes in when it comes to major upgrades in future Smile
= = = = =
The more you laugh...the longer you live.
= = = = =
[Image: userbar.gif]
= = = = =
Not sure if this war reported yet but after upgrading from 1.2.0 to 1.2.1 I get this error when opening the user CP:

Quote:MySQL error: 1054
Unknown column 'r.crs_pid' in 'on clause'
Query: SELECT r.*, p.subject, p.tid FROM srcds_reputation r LEFT JOIN srcds_posts p ON (p.pid=r.crs_pid) WHERE r.uid='1' ORDER BY r.dateline DESC LIMIT 0, 10
Hollanda Wrote:Not sure if this war reported yet but after upgrading from 1.2.0 to 1.2.1 I get this error when opening the user CP:

Quote:MySQL error: 1054
Unknown column 'r.crs_pid' in 'on clause'
Query: SELECT r.*, p.subject, p.tid FROM srcds_reputation r LEFT JOIN srcds_posts p ON (p.pid=r.crs_pid) WHERE r.uid='1' ORDER BY r.dateline DESC LIMIT 0, 10

You must have modified it because crs_pid isn't a column in the posts table.
Ok how do I do that (understandable for a total SQL noob) =)
I upgraded to 1.2.1 but it still says that I'm running mybb 1.2 and it's telling me to upgrade to 1.2.1, but I already did that so obviously I can't upgrade again. What should I do?
azcoyote Wrote:
judel Wrote:Well, since I still don't even know exactly how to upload a backup, that might prove difficult anyway!  LOL

Judel, this program is awesome.  http://www.mysqldumper.de/de/index.php  It takes all the guess work out of it.  One click backs up, one click restores.

tikitiki Wrote:http://www.mysqldumper.de/en/index.php <-- english  I also use this to import my forum
Don't know how I missed these!  Thanks you guys!  I'll be sure to keep that url handy in case I need it!  Big Grin  Though are you sure the English url is correct, Tiki?  I get an error message that it doesn't exist??

EDIT: I checked and the correct URL is http://www.mysqldumper.de/v2/en

Chris Wrote:If you wish to fix the version number yourself, open up inc/class_core.php

PHP Code:

var $version = "1.2";

Replace it with:

PHP Code:

var $version = "1.2.1";
If you've already upgraded, GMX, then this should stop the requests to upgrade??? At least I think it should!
Jude

If I post in your thread, please do not PM me for more help! Thanks!




Forum Jump:


Users browsing this thread: 1 Guest(s)