Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Internal Server Error on first page
Not Solved
Hello, I have successfully installed myBB on a CentOS 6 linux server and am now attempting to test the merge feature to move the old phpBB3 database tables over to it.

Whenever I try to load the initial merge page ( the browser icon spins and spins for several minutes. From my server (via top) I see the memory grow from an initial ~200MB to 900M+ (it has 1GB) and then it starts using swap memory until that grows past 1GB as well.

Finally the browser gives up and spits out this generic message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I have searched this forum and the Internet regarding similar messages but not found any leads. If I look at the error_log for the domain all I see is this:

[Fri Nov 02 11:18:09 2012] [warn] [client] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Fri Nov 02 11:18:10 2012] [error] [client] Premature end of script headers: index.php

Incidentally, if I mod the index.php page to echo something and exit at random places it works anywhere up to line 673. This gives me output after a few seconds:

echo "test"; exit(0);
$debug->log->event("Showing first agreement/welcome page");

This spins, gobbles up memory, and errors:

$debug->log->event("Showing first agreement/welcome page");
echo "test"; exit(0);

Do I not have enough memory to run this? Do I have a configuration error somewhere? Not sure what to try... I've already restarted services, rebooted the server, redownloaded and reuploaded the merge files. I have full access to the server, which could be helpful.... or dangerous Undecided Thanks.
Not Solved
This user has been denied support. This user has been denied support.
i have a pm on you
Not Solved
Not sure why the debug would do that, but try commenting out the line. It's just debug, the script should run fine without it.
-Paul H.

Cogisne lingua latina?
Not Solved
I tried that before and it just hung on the next line. Although I tried again and got it to print through print_header and the next few lines, but only if I told it to exit afterwards. Trying to get it to print_footer but it seems to be hanging. Almost like the server keeps getting to points where it can't handle everything in memory... is 1GB memory low for this? It's just our test box but I'd like to run it successfully before putting it on our live server. For now I guess I'll try commenting out some more stuff to see if I can coax it some more.

OK, I think I figured it out. I forgot that after I installed the forum, I limited the DB permissions on the server for the DB user to Select/Insert/Update/Delete/Execute to see if the forum would work clamped down like that (didn't see any documentation on necessary permissions, but I confess I didn't look that hard). But I forgot I still needed to merge... looking at the debug class I see that it tries to create tables for debugging, but it didn't have permission to do that. So I think that's what was causing it to hang. I restored the permissions and reloaded all the files and it looks like it's working. I'll post again once it completes. Thanks.

Completed successfully. Should I submit a bug report about the script hanging if it tries to create a table when it doesn't have permission? Or is that not worth it since I basically caused it myself? What is the minimum permissions needed for the database anyway? Thanks for helping me point myself in the right direction.

Forum Jump:

Users browsing this thread: 1 Guest(s)