Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shoutbox loading issue again
#1
Hi,

I've got this problem I've had few times where the shoutbox keeps says.... Loading.

Here is my URL: www.ultimategamingforums.co.uk

Take a look and if you can help me great!
Reply
#2
You're loading jQuery 3 times in your headerinclude template:

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js"></script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js" type="text/javascript"></script>

<script src="http://code.jquery.com/jquery-latest.js"></script>

Please navigate to AdminCP -> Templates & Style -> Your Theme's Templates -> Ungrouped Templates -> headerinclude

You can remove two of the codes above. I recommend removing the first two, then replacing:

<script src="http://code.jquery.com/jquery-latest.js"></script>

with:
<script src="http://code.jquery.com/jquery-latest.js"></script>
<script type="text/javascript">jQuery.noConflict();</script>
[Image: information.gif] MyBB Support Technician
Please do not PM me for support.


MyBBatically - A quick and easy way to update your board!
Reply
#3
Its still not worked, I've put a test account in private section. thanks
Reply
#4
This still has not worked, I've done everything and its not working
Reply
#5
Any help this really isn't working for me and i've reinstalled, changed theme everything. HELPP
Reply
#6
Quote:Any help this really isn't working for me and i've reinstalled, changed theme everything. HELPP

Theme has nothing to do with it. Its simple fact you load jquery way to many times.

Anyways do the following:

Post the header include template here. Then we can fix it for you.
Reply
#7
I am currently at college and my forum is blocked as its gaming, can't you use firebug to see my header include?.
Reply
#8
Well we told you what you had to change but you didn't so now just post it, we give you the correct one back.
Reply
#9
I did change it actually and it didn't work, i'll post it now the headerinclude:
<script type="text/javascript">jQuery.noConflict();</script>
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>
{$stylesheets}
<script type="text/javascript">
<!--
var cookieDomain = "{$mybb->settings['cookiedomain']}";
var cookiePath = "{$mybb->settings['cookiepath']}";
var cookiePrefix = "{$mybb->settings['cookieprefix']}";
var deleteevent_confirm = "{$lang->deleteevent_confirm}";
var removeattach_confirm = "{$lang->removeattach_confirm}";
var loading_text = '{$lang->ajax_loading}';
var saving_changes = '{$lang->saving_changes}';
var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
var my_post_key = "{$mybb->post_code}";
var imagepath = "{$theme['imgdir']}";
// -->
</script>
{$newpmmsg}

<script type="text/javascript" src="http://code.jquery.com/jquery-latest.min.js"></script>
<script type="text/javascript">jQuery.noConflict();</script>
<script type="text/javascript">
jQuery.noConflict();
jQuery(document).ready(function() {

jQuery('a[href=#top]').click(function(){
jQuery('html, body').animate({scrollTop:0}, 'slow');
return false;
});

});
</script>
Reply
#10
You either forgot a line or a plugin is adding jquery to the top of the page in a really poor way.

Anyways looking at your source you load it twice. And seeing where it is placed (just below the title) i think you have a plugin doing this.

Try this:

<script type="text/javascript">jQuery.noConflict();</script>
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>
{$stylesheets}
<script type="text/javascript">
<!--
var cookieDomain = "{$mybb->settings['cookiedomain']}";
var cookiePath = "{$mybb->settings['cookiepath']}";
var cookiePrefix = "{$mybb->settings['cookieprefix']}";
var deleteevent_confirm = "{$lang->deleteevent_confirm}";
var removeattach_confirm = "{$lang->removeattach_confirm}";
var loading_text = '{$lang->ajax_loading}';
var saving_changes = '{$lang->saving_changes}';
var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
var my_post_key = "{$mybb->post_code}";
var imagepath = "{$theme['imgdir']}";
// -->
</script>
{$newpmmsg}

I remove this part:

<script type="text/javascript" src="http://code.jquery.com/jquery-latest.min.js"></script>
<script type="text/javascript">jQuery.noConflict();</script>
<script type="text/javascript">
jQuery.noConflict();
jQuery(document).ready(function() {

jQuery('a[href=#top]').click(function(){
jQuery('html, body').animate({scrollTop:0}, 'slow');
return false;
});

});
</script> 

Since you dont have such a button to scroll back to the top anyways. And you load jquery for the second time there.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)