Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Character count settings give me a warning I don't understand
#1
Not Solved
When determining how many characters a post can have, I'm told this:

This should correlate with the message column type in the posts database table, and adjust accordingly. Below are the maximum lengths for each column type.
TEXT: 65535 (default)
MEDIUMTEXT: 16777215
LONGTEXT: 4294967295


I was wondering if I could get some clarification on what that means, and where to actually do whatever it's asking me to do?

I'd like to either set it at the LONGTEXT amount, or actually set it at "0" for unlimited. I have a feeling I shouldn't just ignore that warning message though... so what's my best bet for doing either of those? Also, is there any disadvantage to just setting it at 0/unlimited?
#2
Not Solved
When you set it to 0, MySQL will just cut the message after the number of characters mentioned in the given description.
[Image: banner.png]
#3
Not Solved
(2013-01-25, 08:25 AM)StefanT Wrote: When you set it to 0, MySQL will just cut the message after the number of characters mentioned in the given description.

Not sure what you mean.

I'm asking what does that warning message mean for me to actually do if I want to use the "LongText" amount of characters or if I want to set it to unlimited.

It sound like you just said that setting it to 0/unlimited will actually still get cut off at some amount of characters but I have no idea how that answers what I am asking.

Can you or someone else clarify? What do I do if I want the LongText amount, and what do I do to set it to unlimited without anything getting cut off?

What's this line asking me to physically do? ---> This should correlate with the message column type in the posts database table, and adjust accordingly

It makes no sense to me.
#4
Not Solved
Basically, the message column has a type. It could be (for example), INT, VARCHAR, TEXT, etc.

If you change the type to (for example) LONGTEXT, you should make sure the character count is properly set to 4294967295. I assume that if you don't, nothing bad would happen. However, if you try to set a value higher than your type, I'd assume you'd run into SQL errors when you tried to submit a message longer than you should.

Basically, the default type is TEXT, so don't make it larger than 65535.
Please don't PM me for support. Smile
#5
Not Solved
(2013-01-25, 09:12 AM)Seabody Wrote: If you change the type to (for example) LONGTEXT

Yes, I'd like to change it to LONGTEXT.

Where and how do I do that?

From there, I'll go ahead and set the character length to the appropriate number in the ACP. I'm looking at MyPHPAdmin and I'm in the "posts" section like the original message suggests to me.

What do I do from here...

Ah it seems to be in the "structure" area. I think I've got it...


Forum Jump:


Users browsing this thread: 1 Guest(s)