Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 8 Years, 4 Months ago Private messages are disabled...?
#1
Solved: 8 Years, 4 Months ago
Hello,

on my forum I have Private messaging enabled but it's disabled in members profile. How can I fix this? Thanks for any help!

Permissions:
   

Profile Where it's Blank:
   
#2
Solved: 8 Years, 4 Months ago
check whether below code exists in member_profile template
<tr>
<td class="{$bgcolors['pm']}"><strong>{$lang->pm}</strong></td>
<td class="{$bgcolors['pm']}"><a href="private.php?action=send&amp;uid={$memprofile['uid']}">{$lang->send_pm}</a></td>
</tr>
if it does not then you can add it after any of </tr> code
#3
Solved: 8 Years, 4 Months ago
Each user has a setting in their options: "Receive private messages from other users."
Maybe they have it disabled.
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#4
Solved: 8 Years, 4 Months ago
All of the code is there. All older members are showing like above....

When new members join it shows.
#5
Solved: 8 Years, 4 Months ago
you can run below SQL query through phpMyAdmin
UPDATE `mybb_users` SET `receivepms`=1 WHERE `receivepms` =0
#6
Solved: 8 Years, 4 Months ago
That fixed it! Thanks so much .m.
#7
Solved: 8 Years, 4 Months ago
Note that if the user disables PM again, their link will disappear.
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#8
Solved: 8 Years, 4 Months ago
Thanks for the sql query .m. fixed the same problem for me.

However all my new registrations are being set as NO and i need it to be Yes.

Any ideas on how to fix?
#9
Solved: 8 Years, 4 Months ago
^ you can try SQL query like below
ALTER TABLE `mybb_users` CHANGE `receivepms` `receivepms` INT  NOT NULL DEFAULT 1
#10
Solved: 8 Years, 4 Months ago
Cheers buddy, prompt as always Big Grin
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)