anyone want to test my new MediaWiki user bridge?
#11
then you need to set the cookie domain to .gameofthronestr.com and try it again
Lost interest, sold my sites, will browse here once in a while. It's been fun.
Reply
#12
(2013-11-25, 03:22 AM)pavemen Wrote: then you need to set the cookie domain to .gameofthronestr.com and try it again

OK. Now, it's work fine. Thank you for help pavemen!
Reply
#13
Working fine, only i get a warning on the wiki:

Strict Standards: Declaration of Auth_MyBB::modifyUITemplate() should be compatible with AuthPlugin::modifyUITemplate(&$template, &$type) inC:\xampp\htdocs\aa_neu\w\Auth_MyBB.php on line 248
Reply
#14
sounds like a version issue. what version of MediaWiki are you running?
Lost interest, sold my sites, will browse here once in a while. It's been fun.
Reply
#15
That would be the latest, 1.22.0. The board is running on 1.6.11.

btw, adding &$type to the function declaration seems to fix it^^
Reply
#16
Hello, thanks for the plugin!

There is just error with users who has diacritical symbols in their usernames (f.e. ļāšķž).

While trying to open wiki, they get message stating:
MediaWiki internal error.

Exception caught inside exception handler.

Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information.

When setting this parameter wgShowExceptionDetails to true, MediaWiki loads blank and does not show any message.

Could you help me fix this error?
Reply
#17
please post your LocalSettings.php (or PM it to me)
Lost interest, sold my sites, will browse here once in a while. It's been fun.
Reply
#18
Here you go! I removed sensitive information. Smile


Attached Files
.php   LocalSettings.php (Size: 5.86 KB / Downloads: 153)
Reply
#19
so it works for users with "regular" characters? what are the encoding types (character types) on the mybb and mediawiki tables? You can check via phpmyadmin.
Lost interest, sold my sites, will browse here once in a while. It's been fun.
Reply
#20
Collation for MediaWiki is binary,
Collation for mybb is utf8_general_ci.

So I guess problem is here?

Yes, it works with regular characters, but for diacritical characters users are not saved correctly in MediaWiki user table:
1) if username stars with special letter, user is not saved at all;
2) if username contains special letter, it saves username like f.e. '449e697261'.

I'm not very advanced user so any help is greatly appreciated. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)