Thread Rating:
  • 21 Vote(s) - 4.52 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] MyFacebook Connect 3.4
MyFacebook Connect 3.3 is out
This is a bugfix and feature release.

For the complete changelog, the download link and other informations, read the release thread.
[Image: fSGNVQj.png]
Reply
MyFacebook Connect 3.4 release candidate: https://github.com/Shade-/MyFacebook-Connect

The upcoming version fixes 1 reported issue which is crucial to link existing accounts to their Facebook's. It also updates Facebook's SDK to the latest available (5.6.3) which is deemed to fix PHP 7.2 incompatibilities, and switches to default graph API version 2.12 from 2.8 (nothing should have been changed from reading Facebook's changelogs, but testing is needed).

If you want to contribute, please download MFC 3.4 from GitHub, install/upgrade it on your board after you have backed up your db and files; and report any issue you might find. Thank you.
[Image: fSGNVQj.png]
Reply
I updated to v3.4 to help with testing. Seems to be fine. Except one thing I reported really long time ago - I have one option empty, it is there from one of the older version... who knows, every time updated via update script in ACP.

https://imgur.com/Th4oaf2

Thank you very much for your contribution to MyBB community!
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
MyFacebook Connect 3.4 is out
This is a bugfix, update and feature release.

For the complete changelog, the download link and other informations, read the release thread.
[Image: fSGNVQj.png]
Reply
Is there a way to disable asking for Location & birthday as in not needing to request extra permissions for the app and just use the default permissions? The user should be able to update it later on in the usercp if they wish to.

The problem is with all the recent changes around privacy and GDPR, requesting extra permissions is a painful process having to go through multiple levels of proving to FB and the app is failing new registration without enabling these extra permissions.
Reply
Hi, yes, there is an optout option starting from 3.3 onwards that lets you choose which permissions scopes should not be asked to the user. Location and birthday are currently the only supported scopes you can select. You can find the option in MFC's settings panel.
[Image: fSGNVQj.png]
Reply
Hello Shade, thanks for your work. I am getting 443 not open error, I have SSL working (Comodo PositiveSSL) and I clicked "here" but keep getting a MySQL database error when doing that.

SQL Error:
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1
Query:
ALTER TABLE mybb_users ADD ()

Thanks for any assistance
Reply
Thank you for your report. Please upload the current GitHub version and report any further issues you may find. Your installation attempts have produced duplicate columns in the database which are now conflicting, but a flaw in the code was found and patched so it should work fine now. Only inc/plugins/myfbconnect.php has changed, so you can replace just that file if you want.
[Image: fSGNVQj.png]
Reply
Hi,
i install this plug but have got this error. Anyone can help me?

Invalid Scopes: user_location, user_birthday. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.facebook.com/docs/fac...ermissions

i can try delete class_facebook inside code user_location, user_birthday. but still i got error
Reply
Please read this.
[Image: fSGNVQj.png]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)