Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
themes security problem
#1
hi , i get error when uploading new theme mi-blue


    A potential security issue was found in the theme. It was not imported. Please contact the Author or MyBB Group for support.


Attached Files
.xml   MIBlue.xml (Size: 100.27 KB / Downloads: 163)
#2
I get the same error when trying to import a theme. When I looked for answers in Google, it took me here (the other results were scripts on Github). Rather than make a new thread, I thought I'd bump this and inquire as to why this occurs. It's a really vague error and I'm pretty bummed out because of that.
#3
What it usually is is a typo when the author created the theme. The one I remember most is the typo of
$mybb-settings["variable_here"] 
instead of
$mybb->settings["variable_here"]
.
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
#4
given attachment (MIBlue.xml) is successfully imported in a local test board (MyBB 1.6.9) by ignoring the version.
#5
I just upgraded to MyBB 1.6.10 and decided to re-import my style's templates for safe measure. That is what is prompting the error. I'm only importing templates and I am ignoring version number. I'm not sure exactly when the 1.6.10 release came out, but the OP was yesterday, so he may be using that release as well.

At any rate, I've attached the theme I'm attempting to import and in the meantime, I'll be looking for a typo, namely the one specified formerly.


Attached Files
.xml   BlackEvo4-sweet-theme.xml (Size: 176.13 KB / Downloads: 249)
#6
^ if you already have the theme installed then it is suggested to use Find Updated Templates
to get the required changes and modify templates manually

admin panel >> templates >> Find Updated Templates
#7
That ship already sailed. I reverted them all, which I know was a bad idea. At this point I'm going to uninstall the theme completely and see if I can just reinstall the whole thing from scratch.

EDIT: Aaand that didn't work either. Same vague error. Short of reinstalling MyBB altogether, I'm not sure what to do. If I had to guess, I'd say it has something to do with my recent upgrade. Luckily I backed up my database.

Regardless of what I may have done wrong, or what the issue is, I'd really appreciate more detailed error handling feedback in the control panel. When something doesn't work for seemingly no reason, it tends to frustrate the user.
#8
^ hmm., suggestion is not to revert, but make changes manually. anyway, I've to check it on MyBB 1.6.10
#9
I knew it was a bad idea when I did it, but I was really behind on template updates, so I figured I'd just revert them and then reinstall the template pack. Seems like a pretty straightforward plan, but not so apparently.
#10
This user has been denied support. This user has been denied support.
You'd have to remove the security check, import, put security check back in, then under Tools -> Check Templates find all affected templates and fix them.

Maybe MyBB should allow the import regardless, just not allow users selecting a theme using that templateset until the issues are fixed.

Reinstalling the template pack doesn't fix anything in the first place, by the way (unless the author of the theme updated in the meantime). The templates are still old; and you still have to apply any updates manually to them.


Forum Jump:


Users browsing this thread: 1 Guest(s)