Discuss: MyBB 1.2.2 Released
#41
arashpour Wrote:So I close down m,y forums!!!! THANKS A LOT!!!

How rude are you screaming at me when I'm being realistic.
#42
arashpour Wrote:I upgraded and everything should have looked fine. but after the upgrade it says:
Fatal error: Call to undefined function iif() in /home/tehranta/public_html/global.php(316) : eval()'d code on line 1

The admin CP works perfectly. Not the forums. why??

List the mods you have. Also make sure to reupload the global.php.

If you need this iif function look for it in the old function files and just add it yourself.
#43
DrPoodle Wrote:
judel Wrote:
drpoodle Wrote:I am soaked, and really shouldn't be using this compu...BZZZZZZTTT!!!!
LMAO! Thanks for the laugh! I always like to start my day with a good one! Big Grin
Which time zone are you in??? I posted that after I left work at 4:30pm!!! lol

My time zone is Pacific Standard Time. LOL...live in California in the good ole U S of A! Wink By the way as a point of reference, it was 8:55 in the morning here when you posted that!

And it looks like I will definitely delay upgrading for a few days until the worst of the bugs have been worked out! I'm scared already!
Jude

If I post in your thread, please do not PM me for more help! Thanks!


#44
labrocca Wrote:
arashpour Wrote:I upgraded and everything should have looked fine. but after the upgrade it says:
Fatal error: Call to undefined function iif() in /home/tehranta/public_html/global.php(316) : eval()'d code on line 1

The admin CP works perfectly. Not the forums. why??

List the mods you have. Also make sure to reupload the global.php.

If you need this iif function look for it in the old function files and just add it yourself.
It's just that he doesn't have the iif function on the board. Which leads to that error in a template. global.php doesn't really have any code related to it.

judel Wrote:My time zone is Pacific Standard Time. LOL...live in California in the good ole U S of A! Wink

And it looks like I will definitely delay upgrading for a few days until the worst of the bugs have been worked out! I'm scared already!
What bugs? I see no bugs? I see people reporting something they are guilty of themselfs.
#45
No i dont have conditional mod. I also rewrote the whole files which were updated it wans useful. I have these plug ins: (all deactivated)
Birthday Mailer
Board Message
Douple Post Auto Merger
Email Notification on Registration
Extra fields for posts
Forum stats in profile
Game section
Hello World!
*<imei> HighLight!
Important messages on index.
invite new user
Multiple reputations
Name BBCode
Inline thread popup
Cannot send PM's To self
Post On Registration
Prevent Used Emails from being Re-registered
Resize Textarea
Restricted private messages
Restrict Moderators Editing
Status in profile
thread viewer
Thank you
Trash Can Forum
Usergroup additional images
viewe post
Who Voted
#46
judel Wrote:And it looks like I will definitely delay upgrading for a few days until the worst of the bugs have been worked out! I'm scared already!
What bugs? I upgraded my forums fine using the changed files zip archive, no problems here...

arashpour Wrote:No i dont have conditional mod. I also rewrote the whole files which were updated it wans useful. I have these plug ins: (all deactivated)
Birthday Mailer
Board Message
Douple Post Auto Merger
Email Notification on Registration
Extra fields for posts
Forum stats in profile
Game section
Hello World!
*<imei> HighLight!
Important messages on index.
invite new user
Multiple reputations
Name BBCode
Inline thread popup
Cannot send PM's To self
Post On Registration
Prevent Used Emails from being Re-registered
Resize Textarea
Restricted private messages
Restrict Moderators Editing
Status in profile
thread viewer
Thank you
Trash Can Forum
Usergroup additional images
viewe post
Who Voted
Have you modified any files from their original state?
jsoltesz.com - MyBB lead designer & team member since 2006
#47
arashpour Wrote:No i dont have conditional mod. I also rewrote the whole files which were updated it wans useful. I have these plug ins: (all deactivated)
You are using iif in your templates. If you don't want this you should revert the templates back to original state.

If you wish to fix it another way. Read here.
#48
I really regret upgrading this time...Sad
I am gonna reinstall 1.2.1 from scratch again!
thanks
#49
Why not just install 1.2.2 from scratch then if you really are going to install from scratched. Although I don't see why at all.

As I said. This is NOT a problem with 1.2.2, it's your template set.
#50
The upgrade (from 1.2.1 to 1.2.2) itself worked fine for me, but I have a problem with getting the themes to work. Seems like the new version simply doesn't care what theme a user wants - on the startpage, user-cp, calendar etc. the standard theme is shown, regardless of what is chosen. Only in showthread.php and forumdisplay.php the chosen theme is used. (Before the upgrade everything worked as it should.)

I even tried a completely fresh 1.2.2 installation and it didn't work either. I have absolutely no clue why it doesn't work for me but seems to be fine for everyone else... :-(

My themes all depend on the standard templates, so even after some of them beeing reverted the colors etc. should be like defined in the theme. (And every single theme works fine as soon as i set it as standard theme!)

Hints and ideas will be highly appreciated...


Edit:
http://community.mybboard.net/showthread.php?tid=14204
http://community.mybboard.net/showthread.php?tid=14198


Forum Jump:


Users browsing this thread: 1 Guest(s)