Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solutions for Missing Mycode Editor
#1
Many MyBB software users report their MyBB editor is missing due to various reasons which I'll cover in this tutorial.
Before we start, we need to be sure that the MyBB editor is actually enabled on your account and for the entire
board.

To enable mycode editor for entire board: Go to ACP>Configuration>Settings>Clickable Smilies and BB Code>Clickable MyCode Editor>Tick ON

If the above setting is on but you still can't see the mycode editor but everyone else can then most likely you don't have it enabled through your UserCP.

Go to UserCP>Edit Options>Other Options>Tick Show the MyCode formatting options on the posting pages.

Now if you have both the above settings enabled and you still can't see the mycode editor then you are most likely missing something. Below I'm going to present some solutions in order of most likely the cause of the issue.

Solution # 1

Skip this solution if you are not using Cloudflare.

  • Log in to your Cloudflare
  • Edit Settings
  • Click on Performance tab
  • Disable Rocket Loader and/or Auto Minify

Solution # 2


Go to ACP>Templates & Styles>Themes>YOUR THEME>Editor Style>Change it to Office 2007

If this solution works then it means that there's a problem with your editor theme files.

Solution # 3

Reupload jscripts_themes folder in .jscripts/jscripts_themes and make sure you have a file called editor.js in .jscripts

Solution # 4

Download a fresh copy of MyBB from MyBB Downloads

Then reupload the codebuttons folder in .images and .images/themes.

Solution # 5

Go to ACP>Templates & Styles>Templates>YOUR THEME>Newthread
And
Go to ACP>Templates & Styles>Templates>YOUR THEME>Newreply

Make sure you have the following code:

{codebuttons}

Right after

<textarea name="message" id="message" rows="20" cols="70" tabindex="2">{$message}</textarea>

Solution # 6

This solution is only valid if the editor went missing after you upgraded or downgraded your forum.

Find updated templates for your current theme and revert them to original.

Go to ACP>Templates & Styles>Templates>Find Updated Templates

Solution # 6
Thanks to Effone

Go to ACP>Templates & Styles>Templates>YOUR THEME>Ungrouped Templates>Headerinclude

Add the following at the very end of your headerinclude template:

<script type="text/javascript">jQuery.noConflict();</script>

Also, please refer to post # 10 on this thread for further information on solution # 6.

Solution # 7 Thanks to Meadp

If the codebuttons are showing for you and only few members are unable to see it then you can run the following query to enable "Show the MyCode formatting options on the posting pages" for the whole board through this SQL query:

UPDATE `mybb_users` SET `showcodebuttons` = '1' WHERE `showcodebuttons` = '0'

Hope you liked my guide. If you are still facing an issue then feel free to post below. I would appreciate all kinds of feedback on this guide.
Reply
#2
Well, but sometimes it happens in case of a jQ conflict. Have you mentioned that?
Reply
#3
(2013-08-06, 01:46 PM)effone Wrote: Well, but sometimes it happens in case of a jQ conflict. Have you mentioned that?

Oh yes. You are correct but that only happens if someone is using jQuery like for example jQuery collapse siderbar, jQuery collapse images, jQuery modal login, etc. I'll still add it to the list. Thanks!
Reply
#4
i have a problem with my mycode editor. When i clicked on full edit. The mycode editor didnt display

[Image: no_editor_tools_in_edit_post.png]
Reply
#5
The image seems to be broken.
Reply
#6
I recommend also this query:

UPDATE `mybb_users` SET `showcodebuttons` = '1' WHERE `showcodebuttons` = '0'
Reply
#7
Thanks! I've updated the guide and provided the necessary credit(s).
Reply
#8
Nice Share >> Smile
Reply
#9
(2013-08-06, 01:34 PM)Arbaz Wrote: Many MyBB software users report their MyBB editor is missing due to various reasons which I'll cover in this tutorial.
Before we start, we need to be sure that the MyBB editor is actually enabled on your account and for the entire
board.

To enable mycode editor for entire board: Go to ACP>Configuration>Settings>Clickable Smilies and BB Code>Clickable MyCode Editor>Tick ON

If the above setting is on but you still can't see the mycode editor but everyone else can then most likely you don't have it enabled through your UserCP.

Go to UserCP>Edit Options>Other Options>Tick Show the MyCode formatting options on the posting pages.

Now if you have both the above settings enabled and you still can't see the mycode editor then you are most likely missing something. Below I'm going to present some solutions in order of most likely the cause of the issue.

Solution # 1

Skip this solution if you are not using Cloudflare.

  • Log in to your Cloudflare
  • Edit Settings
  • Click on Performance tab
  • Disable Rocket Loader and/or Auto Minify

Solution # 2


Go to ACP>Templates & Styles>Themes>YOUR THEME>Editor Style>Change it to Office 2007

If this solution works then it means that there's a problem with your editor theme files.

Solution # 3

Reupload jscripts_themes folder in .jscripts/jscripts_themes and make sure you have a file called editor.js in .jscripts

Solution # 4

Download a fresh copy of MyBB from MyBB Downloads

Then reupload the codebuttons folder in .images and .images/themes.

Solution # 5

Go to ACP>Templates & Styles>Templates>YOUR THEME>Newthread
And
Go to ACP>Templates & Styles>Templates>YOUR THEME>Newreply

Make sure you have the following code:

{codebuttons}

Right after

<textarea name="message" id="message" rows="20" cols="70" tabindex="2">{$message}</textarea>

Solution # 6

This solution is only valid if the editor went missing after you upgraded or downgraded your forum.

Find updated templates for your current theme and revert them to original.

Go to ACP>Templates & Styles>Templates>Find Updated Templates

Solution # 6
Thanks to Effone

Go to ACP>Templates & Styles>Templates>YOUR THEME>Ungrouped Templates>Headerinclude

Add the following at the very end of your headerinclude template:

<script type="text/javascript">jQuery.noConflict();</script>

Solution # 7 Thanks to Meadp

If the codebuttons are showing for you and only few members are unable to see it then you can run the following query to enable "Show the MyCode formatting options on the posting pages" for the whole board through this SQL query:

UPDATE `mybb_users` SET `showcodebuttons` = '1' WHERE `showcodebuttons` = '0'

Hope you liked my guide. If you are still facing an issue then feel free to post below. I would appreciate all kinds of feedback on this guide.

The editor issue almost always happens in the back end because of Rocket Loader. Site owners using CloudFlare, however, can set a PageRule to exclude CloudFlare's performance features from URLs to solve the issue as well.
Damon, CloudFlare Community
Tips for using MyBB with CloudFlare
Reply
#10
Solution #6 is partially invalid and incomplete.

Firstly,
<script type="text/javascript">jQuery.noConflict();</script>
should be added just after jQuery is loaded, not at the end of headerinclude.

Secondly, it's important to load only 1 version of jQuery. So if you see multiple instances of jQuery in <script> src attribute during viewing your page's source code, remove older versions and leave only one.

Thridly, make sure all $ for selectors/etc. in jQuery scripts only (if you don't know how to identify them, better ask, don't try yourself because you can possibly break more things. Also $ can be used in variables) are replaced with jQuery or the beginning of function tells $ are allowed:
jQuery(document).ready(function($){ 
//rest of code, can use $ without a problem because of function($)
}
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)