Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved global.lang.php does not exist
#1
Not Solved
I just completed a fresh install.
When I attempt to get at the forum, I get:
/inc/languages/english/global.lang.php does not exist
When I attempt the admin panel:
Your forum does not contain an Administration set. Please reupload the english language administration pack.


I have confirmed that global.lang.php is present. However, the permission may be the issue. After the install ftp via windows 7 fails to access the english directory. Checking the permissions
web User : Read, Write, No execution
Owner: Read, Write, No execution.

I followed the install directions and changed the permissions to 6 for the two above. This was after ftping the files. Was I suppose to go back and change the permissions after install?


I changed the permissions to
Web: Read, no write, executable
owner: Read, write, executable

and now it works. But I feel I may have compromised security. What should the permission be set to?

Since there are php files in the english directly, should the executable permission be set?
#2
Not Solved
see required permissions for files & folders
#3
Not Solved
I followed the install instructions and chmod as required, yet I ended up with the issue above.

I did delete the install directory and CHMOD config.php back to 644.

But that was not enough. Perhaps its a godaddy thing, but I had to make the "english" directory:
web user: Read
Owner: Read, Execute
#4
Not Solved
^ are you using a ftp client (eg. filezilla) - if not I'd suggest to use it
if you use firefox browser then you can also use FireFTP add-on


Forum Jump:


Users browsing this thread: 1 Guest(s)