Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 9 Years, 1 Week ago The "Lock" File
#1
Solved: 9 Years, 1 Week ago
I did a search for it, but the best I could find was the issue of Lock after upgrading.

Trying to upgrade from 1.6.8 to 1.6.11.

The problem is, I'm getting a message that says I have to remove Lock from the install folder. Which I did. But it still says the same thing, even after I cleared my cache.

This has been independently verified by two of my mods who tried to access upgrade.php. For some reason, we still get the "remove lock" error "Error
The installer is currently locked, please remove 'lock' from the install directory to continue" despite Lock being... well... gone.

What should I do?
#2
Solved: 9 Years, 1 Week ago
./install/lock needs to be renamed or deleted.

Please delete the entire ./install directory and upload it from 1.6.11 Release Package (MD5: 918be9675d3d50c63bfe4c6cbf17fd0f).

Are you completely sure that you have uploaded all of the files from the above package? - If so there shouldn't be any problems. Smile
#3
Solved: 9 Years, 1 Week ago
No need to delete the install directory really, just upload one over top of the other and delete /install/lock. Wink
#4
Solved: 9 Years, 1 Week ago
I've reuploaded the whole install directory, and I've already deleted lock, and cleared my cache. For some reason, it still gives that, even though I already removed lock.

This most recent time, I've uploaded the install directory from that link you gave me. There isn't even a lock file in the install directory, and yet I'm getting the same error.

=/
#5
Solved: 9 Years, 1 Week ago
Maybe you are looking in the wrong directory? It is almost impossible to get that error when there is no lock file.
[Image: banner.png]
#6
Solved: 9 Years, 1 Week ago
In your image file you have an SQL error and it's not for your lock file, only is a fail caused for some reason, maybe a plugin, or some crash of db, you may repair your database, ren plugins dir to plugins_resp or something, try to upgrade, after that you may to find all upgradable plugins and upload again after rename plugins_resp to plugins dir, and its done, if you see an error it's only because you have some plugins not compatibles with latest MyBB version, but you don't have any error if you have all right.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

#7
Solved: 9 Years, 1 Week ago
(2013-11-11, 08:41 PM)StingReay Wrote: No need to delete the install directory really, just upload one over top of the other and delete /install/lock. Wink

I suggested that as from what I saw in their post was that they had tried something similar. Therefore I suggested something other than what had already been done, even though it seems that their solution should work.
#8
Solved: 9 Years, 1 Week ago
Okay. I just downloaded the link you posted, deleted the install folder, and reuploaded it. For some reason, the "lock" file isn't even there, but I'm still getting the error.

Also, we already fixed the other error.


Attached Files Thumbnail(s)
   
#9
Solved: 9 Years, 1 Week ago
The lock file exists, you can access it with your browser: http://secundus.fatenuovoguerra.com/install/lock
[Image: banner.png]
#10
Solved: 9 Years, 1 Week ago
Have you changed your FileZilla settings to hide files with no extension?
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.


Forum Jump:


Users browsing this thread: 1 Guest(s)