Thread Rating:
  • 13 Vote(s) - 3.69 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.6] [AJAX] Inferno Shoutbox for MyBB
(2015-12-30, 01:31 PM)DjPrison Wrote: I have shoutbox loading all the time
[Image: hAXtzHb.png]
And web console is giving me this error: GET http://xxxxx.xxx/inc/plugins/inferno/inferno.js.php     index.php:237
http://xxxxx.xxx/inc/plugins/inferno/inferno.js.php Failed to load resource: the server responded with a status of 500 (Internal Server Error)

And how i can move the shoutbox to Portal.php

Quote:PHP Code:
$plugins->add_hook('index_start', 'inferno_index');
with
PHP Code:
$plugins->add_hook('portal_end', 'inferno_index');

There isnt that code anymore in inferno.php

That's a error on the webserver. What does it's log say? Also, changing code to make it load on the portal shouldn't be needed anymore.
Reply
to show shoutbox on portal just add the variable
{$inferno_shoutbox}
where you want it in portal template
Reply
That's a error on the webserver. What does it's log say? Also, changing code to make it load on the portal shouldn't be needed anymore.

what you mean with loading on the portal? if i want it to portal

Log:
[30-Dec-2015 07:50:12 America/New_York] PHP Fatal error: Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:51:13 America/New_York] PHP Fatal error: Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:51:20 America/New_York] PHP Fatal error: Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:52:38 America/New_York] PHP Fatal error: Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:53:55 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:54:36 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:55:49 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:56:19 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:56:48 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:57:22 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:58:33 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 33
Reply
(2015-12-30, 04:42 PM)subzr1 Wrote: to show shoutbox on portal just add the variable
{$inferno_shoutbox}
where you want it in portal template

I got that, thanks.
But i still have that loading problem
Reply
(2015-12-30, 07:32 PM)DjPrison Wrote: That's a error on the webserver. What does it's log say? Also, changing code to make it load on the portal shouldn't be needed anymore.

what you mean with loading on the portal? if i want it to portal

Log:
[30-Dec-2015 07:50:12 America/New_York] PHP Fatal error:  Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:51:13 America/New_York] PHP Fatal error:  Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:51:20 America/New_York] PHP Fatal error:  Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:52:38 America/New_York] PHP Fatal error:  Call to undefined function inferno_index() in /home/edibzuoe/public_html/inc/class_plugins.php on line 139
[30-Dec-2015 07:53:55 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:54:36 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:55:49 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:56:19 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:56:48 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:57:22 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 32
[30-Dec-2015 07:58:33 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/edibzuoe/public_html/inc/plugins/inferno/class_core.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/edibzuoe/public_html/inc/plugins/inferno.php on line 33

Sorry about taking so long. Could you try reuploading the files and making sure that the permissions are correct (that the webserver can read the files)? Right now it looks like the permissions are bad, so the webserver can't open the file.
Reply
I tried reuploading, and all permissions are 6-4-4 and collapsing wont work.
And if this helps

MyBB Version
1.8.6


PHP Version
5.5.30


SQL Engine
MySQLi 5.5.45


Server Load
9.03
Reply
(2016-01-01, 11:32 AM)DjPrison Wrote: I tried reuploading, and all permissions are 6-4-4 and collapsing wont work.
And if this helps

MyBB Version
1.8.6


PHP Version
5.5.30


SQL Engine
MySQLi 5.5.45


Server Load
9.03

Still getting the same errors? Also, are you by any chance using a free hosting provider (they are known to block all shoutboxes)?
Reply
Still getting error, and no im paying from my hosting
Reply
(2016-01-01, 09:11 PM)DjPrison Wrote: Still getting error, and no im paying from my hosting

I'd use their support then, since the webserver can't access the files it needs to for some reason. That isn't a bug in the shoutbox as far as I can tell.
Reply
Solution: Incorrect permissions in the following directory: public_html/inc/plugins/inferno set 0755 for folders and 0644 for files. After this, the issue seems to be resolved.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)