Thread Rating:
  • 15 Vote(s) - 3.93 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.6] Square Theme
#41
(2014-04-10, 01:47 AM)PwnEm Wrote: Looks sleek, great job.

As for random news, is that what's in the header bar?

Yes, the random news are to the left of the login/user menu.
I don't give support on PM.
#42
This user has been denied support. This user has been denied support.
Amazing theme. Thank you very much indeed!

Im having a 2 very minor issue on my site.

1. I changed the logo and adjusted height of the header and also the padding above the top right links. I noticed when testing that if I go for instance from Home(portal) to Forum the logo goes to the right slightly then back into position.

I've narrowed it down to this bit of code from my forum that causes the jiggle from the header template:

<script language="javascript" src="{$mybb->settings['bburl']}/123flashchat/chatwinsize.php"></script>
<li><a href="javascript:openChat();" title="Chat Room"><i style="font-size: 14px;"></i>Chat</a></li>

url:xxxxxxxxx.com

So it looks like the java bits may be causing this - how can i still link to the chat but not have the jiggly logo.

2. On the portal page if you look at the articles - the headline within the article has a large white space above it. How can I reduce the size of that white space but only on the portal ?

3. How do I change "This is a simple test for news with CSS and jQuery." - is there a setting or do i manually change the code in the header ?

Anyone help would be massively appreciated.

Thanks envy cant wait to see your next theme Smile
#43
1. Please give me your forum url, I don't get it at all, so it's more fast if I see the problem directly. (If you don't want to post the url to the public, send me a pm)

2. I don't even touch a single piece of code of the portal (Only the last threads to link them to the index template). If you can be more specific... I understand you want to reduce the space, but I need to know of which space are you talking about (It's better if you show me a picture with blank space you want to reduce).

3. Manually, in the header template.

Greetings!
I don't give support on PM.
#44
This user has been denied support. This user has been denied support.
Hello mate,

The url was in my post just buried half way down:

1. the form url is www.xxxxxxxx.com - the link to chat seems to cause the issue with the logo jiggle but i dont know how to remedy this.

2. Here is the whitespace i was talking about:
[Image: whitespace.PNG]
Specifically the gap above the black title inside the article - if you look at my front page you'll see these white gaps are quite prominent.

3. thanks - i changed it manually Smile

4. I cant get forum statistics to show in the side box on the forum home - its a blank box - can we change this so box only shows if the option is selected ie show stats + how can I get the stats inside the box instead of blank ??


Thanks for all your help
#45
1. That's because when you change from one site to another, the browser hide the navigation bar, load the new page, and load again the navigation bar if the width/height change.

2. Square templates > Portal templates > portal_announcement:

Copy this and replace all the code inside your theme:

Quote:<table cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead"><strong>{$icon} <a href="{$mybb->settings['bburl']}/{$announcement['threadlink']}">{$announcement['subject']}</a></strong></td>
</tr>
<tr>
<td class="trow7" align="right">
<span class="smalltext">{$lang->posted_by} {$profilelink} - {$anndate} {$anntime} {$numcomments}</span>
</td>
</tr>
<tr>
<td class="trow6">
<table border="0" cellpadding="{$theme['tablespace']}" width="100%">
<tr>
{$avatar}
<td class="trow1">
<p>
{$message}
</p>
{$post['attachments']}
</td>
</tr>
<tr>
<td align="right" colspan="2" valign="bottom">
<span class="smalltext">
<a href="{$mybb->settings['bburl']}/printthread.php?tid={$announcement['tid']}"><img src="{$theme['imgdir']}/printable.gif" alt="{$lang->print_this_item}" title="{$lang->print_this_item}" /></a>&nbsp;<a href="{$mybb->settings['bburl']}/sendthread.php?tid={$announcement['tid']}"><img src="{$theme['imgdir']}/send.gif" alt="{$lang->send_to_friend}" title="{$lang->send_to_friend}" /></a>
</span>
</td>
</tr>
</table>
</td>
</tr>
</table>
<br />

After, go to Styles > Square > global.css, and inside that, paste this:

Quote:.trow6 {
background: #FAFAFA;
padding: 2px 8px;
}

.trow7 {
background: #FAFAFA;
padding: 2px 8px;
}

I think you know what I'm doing, but if you don't... simply change the trow1/2 class for new classes who only be used in the announcements of the portal. That new classes are trow6/7, and after you have the CSS for both classes, you can change the 2px padding to modify top/bottom spacing.

3. Great!

4. Don't get this, you want to display the Stats in the Index page or the Portal page?
I don't give support on PM.
#46
This user has been denied support. This user has been denied support.
Thanks for your help mate!

1. On the forum index the statistics box is blank ? even if i turn on stats in the admin panel

2. If I add links to the top right navigation for example if I add this to the header:


<li><a href="http://xxxxxxxx.com/portal.php" title="Front Page"><i class="fa fa-home fa-fw"></i> News</a></li>
<li><a href="http://xxxxxxxx.com/index.php" title="Cannabis Forum"><i class="fa fa-file-text fa-fw"></i> Forum</a></li>

Then these links log you out, all others do not log you out ??

Ive tried like this:
<li><a href="http://xxxxxxxxxx.com/portal.php"><i class="fa fa-home fa-fw"></i> News</a></li>
<li><a href="http://xxxxxxxxxxx.com/index.php"><i class="fa fa-file-text fa-fw"></i> Forum</a></li>
<li><a href="http://xxxxxxxxxxx.com/calendar.php"><i class="fa fa-calendar fa-fw"></i> Calendar</a></li>
<li><a href="http://xxxxxxxxxxx.com/search.php"><i class="fa fa-search fa-fw"></i> Search</a></li>

etc but any changes i seem to make to the navigation cause logouts ? when i make back to original no logout problem ?

How do I add links to the navigation without the new links causing logouts ?

Thanks
#47
1. I installed the theme and the Statistics works correctly...

2. Well that's not normal... the only thing you're doing is putting links and nothing more... if you click and the forum gives you logout, then something is bad in your forum, not in the theme.

The way you're adding the links is correct.

Try disabling plugins and see if this still happening.
I don't give support on PM.
#48
This user has been denied support. This user has been denied support.
I disabled all plugins - its still the same.

I am now fairly certain ive figured out whats causing it. I am testing now. will update shortly

Okay I dont know why but the login problem goes away if I use links like this:

<li><a href="{$mybb->settings['bburl']}/portal.php"><i class="fa fa-home fa-fw"></i> News</a></li>
<li><a href="{$mybb->settings['bburl']}/index.php"><i class="fa fa-file-text fa-fw"></i> Forum</a></li>

If I use links like this:

<li><a href="http://xxxxxxxxxxxx.com/portal.php"><i class="fa fa-home fa-fw"></i> News</a></li>
<li><a href="http://xxxxxxxxxxxx.com/index.php"><i class="fa fa-file-text fa-fw"></i> Forum</a></li>

I have login problem ??

I still have 2 problems remaining:

1. the forum statistics are blank ? when i turn them on - i get a line right at the bottom of the forum index - when i turn them off the box saying statistics still shows ?

1b. when i enable whos online it is at the bottom of the forum index not to the side - is this meant to be like this ?

2. how do i add a link to my chat in this theme - I try to add this like in my other theme:

<script language="javascript" src="{$mybb->settings['bburl']}/123flashchat/chatwinsize.php"></script>
<li><a href="jopenChat();" title="Chat Room"><i style="font-size: 14px;"></i>Chat</a></li>

I get error and it tries to open:
http://www.xxxxxxxxx.com/jopenChat(); url not found - its like it doesnt recognise the javascript in this header ?
#49
(2014-04-17, 05:57 PM)FCdude Wrote: I disabled all plugins - its still the same.

I am now fairly certain ive figured out whats causing it. I am testing now. will update shortly

Okay I dont know why but the login problem goes away if I use links like this:

<li><a href="{$mybb->settings['bburl']}/portal.php"><i class="fa fa-home fa-fw"></i> News</a></li>
<li><a href="{$mybb->settings['bburl']}/index.php"><i class="fa fa-file-text fa-fw"></i> Forum</a></li>

If I use links like this:

<li><a href="http://freecannabis.com/portal.php"><i class="fa fa-home fa-fw"></i> News</a></li>
<li><a href="http://freecannabis.com/index.php"><i class="fa fa-file-text fa-fw"></i> Forum</a></li>

I have login problem ??

It's the same.

(2014-04-17, 05:57 PM)FCdude Wrote: 1. the forum statistics are blank ? when i turn them on - i get a line right at the bottom of the forum index - when i turn them off the box saying statistics still shows ?

1b. when i enable whos online it is at the bottom of the forum index not to the side - is this meant to be like this ?

I don't know why Statistics don't show, I installed 5 times the theme and the Statistics work correctly. The "Who's online" it's supposed to be there, at the bottom.

(2014-04-17, 05:57 PM)FCdude Wrote: 2. how do i add a link to my chat in this theme - I try to add this like in my other theme:

<script language="javascript" src="{$mybb->settings['bburl']}/123flashchat/chatwinsize.php"></script>
<li><a href="jopenChat();" title="Chat Room"><i style="font-size: 14px;"></i>Chat</a></li>

I get error and it tries to open:
http://www.freecannabis.com/jopenChat(); url not found - its like it doesnt recognise the javascript in this header ?

Well... that's not the best way... I think you need to put this:

script language="javascript" src="{$mybb->settings['bburl']}/123flashchat/chatwinsize.php"></script>

In headerinclude template.

After, in the header template:

<li><a href="jopenChat();" title="Chat Room"><i style="font-size: 14px;"></i>Chat</a></li>

Put that and see if this work.

Also, check the names and if you have correctly the .php file.
I don't give support on PM.
#50
This user has been denied support. This user has been denied support.
Thanks envy Big Grin

Any ideas about how to make the chat link work ?

Figured it out... for some reason the code had changed from:

<script language="javascript" src="{$mybb->settings['bburl']}/123flashchat/chatwinsize.php"></script>
<li><a href="jopenChat();" title="Chat Room"><i style="font-size: 14px;"></i>Chat</a></li>

to:

<script language="javascript" src="{$mybb->settings['bburl']}/123flashchat/chatwinsize.php"></script>
<li><a href="jopenChat();" title="Chat Room"><i style="font-size: 14px;"></i>Chat</a></li>

The first one works the second one doesnt why or how it change i have no idea..

Anyway amazing work and support envy you the man!!!!


Forum Jump:


Users browsing this thread: 1 Guest(s)