Thread Rating:
  • 15 Vote(s) - 3.93 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.6] Square Theme
#11
The issue is with this forum...

when you type in the word "javas_cript" (take out the _) is turns it into a single "j".

I tried posting the issue here around 4 or 5 times and ended up on a captcha page with my message never being changed. So I gave up!

Here attached you'll find the correct code (and some added CSS to align the button properly with the others) and a png for the button multiquote.


Attached Files Image(s)
   

.txt   multiquote.txt (Size: 447 bytes / Downloads: 197)
#12
THanks for the image and the image align fix, but the code still does not work to multiquote.
Also does anyone know how to edit the news feed ticker at the top, seems like a great feature if i can learn to use it.
#13
nice theme Smile
#14
Sorry for not reply before.

For multiquote...

Quote:<a href="javascript:Thread.multiQuote({$post['pid']});" style="display: none;" id="multiquote_link_{$post['pid']}"><img src="{$theme['imglangdir']}/postbit_multiquote.gif" alt="{$lang->postbit_multiquote}" title="{$lang->postbit_multiquote}" id="multiquote_{$post['pid']}" /></a>
<script type="text/javascript">
//<!--
$('multiquote_link_{$post['pid']}').style.display = '';
// -->
</script>

That's the default code for multiquote, and it works, I tested that now in localhost.

For the news... this was my first template, so I do a mistake with the news. You need to edit "header_welcomeblock_guest" and "header_welcomeblock_member".

These are the news:

Quote:<div class="news">
<ul id="tips">
<li>This is a simple test for news with CSS and jQuery.</li>
<li>Please, ignore this message.</li>
</ul>
</div>

You can edit the content of <li> tags, and you can add more if you like (Have in mind the width of the news, because it's in the same place with the login, so, try to place short news).

Greetings, and sorry for my bad english, hope you guys can understand me Toungue.
I don't give support on PM.
#15
can you tell me how you showed last threads in sidebar ?
#16
Sure!

1 - Index template:

You need to separate the forum and the latest threads:

Quote:<div class="sidebar" style="float: right; width: 250px;">

<script type="text/javascript">
jQuery(function(){
jQuery(".latestthreads").load("{$mybb->settings['bburl']}/portal.php .latestthreads_portal");
}); </script>

<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead">
<div class="expcolimage"><img src="{$theme['imgdir']}/collapse.gif" id="ths_img" class="expander" alt="[-]" title="[-]" /></div>
Latest Threads
</td>
</tr>
<tr>
<td class="trow3" style="{$collapsed['ths_e']}" id="ths_e">

<div class="latestthreads float_left">
</div>

</td>
</tr>
</table>

</div>

<div class="forums" style="float: left; width: 714px;">
{$forums}
</div>

If you see there, I have 2 divs, the jQuery script to import the data and the table for the sidebar where you put the latest threads.

I use the class "latestthreads_portal" to import the data from the portal, so...

2- Portal templates > portal_latestthreads_thread

Quote:<tr class="latestthreads_portal">

You simply add the class we use before in the start of the <tr> tag.

And I think that's all. Of course you need to have jQuery in your forum for this to work.

Another thing is... this is already posted here, so if you search a little bit, can find it.

Greetings.
I don't give support on PM.
#17
thanks for your help
+1 rep
#18
Hi again eNvy,

I have a problem with the pop-up window for the smileys (either in the reply form or quick reply form).
The window with the extra smileys opens but freezes maybe 4-5 seconds later and I get this message:

Script : http://www.mywebsitecom/misc.php?action=...eEditor:57

I didn't have this issue on my previous theme. I've tried checking around on mybb but haven't found any working solution. Could you have a look?

Many thanks!
#19
Searching in depth, I found the jQuery code for random news it's the problem there.

Well, I write the manually form to fix this, but the captcha don't show and gives me error and all the tutorial dissapear... so, please, download the .zip file from the mods center when the MyBB Staff approves them once again.

I do several fixes in some little things, and change the code to the news, now works correctly and don't have any problem.

Greetings.
I don't give support on PM.
#20
Thanks eNvy!


Forum Jump:


Users browsing this thread: 1 Guest(s)