Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [Solved] Language switch on Help Documents not working
#1
Not Solved
Hi all,

I have started a MyBB Forum (last version 12) that is working nicely with one exception.

I have the Quick Language Change in the footer and it works correctly except if I want to look at the Help Documents. I get only the english version independantly of the switch position.

However, the header, the breadcrumb are correct in french. Only the 2 sections with the documents are unchanged in english.

I have all files in both english and french directories set up :
/inc/languages/english and /french with :
customhelpdocs.lang.php, customhelpsections.lang.php,
helpdocs.lang.php, helpsections.lang.php

However, if I want to edit them with ACP/Languages, their content does not show up.

Seems to me like a problem in misc.php.

My site : http://condor-velivole.eu/mybb/

Thanks for your answers.
#2
Not Solved
french language pack might be incomplete - have you physically checked contents of the help files (in a text editor)
#3
Not Solved
(2014-02-27, 06:27 PM).m. Wrote: french language pack might be incomplete - have you physically checked contents of the help files (in a text editor)
I have cheked that all the files are present in the french pack and on the site and have the same size.
#4
Not Solved
^ I mean to say, have you checked if the help language files have french text in them ?
#5
Not Solved
(2014-02-27, 06:57 PM).m. Wrote: ^ I mean to say, have you checked if the help language files have french text in them ?
Yes, of course, and I have also checked that the structure of the files are the same in french and english, that there is no syntax error.
I believe the problem is outside these files.
#6
Not Solved
^ just for testing
rename the help related language files in the French directory as .old files & visit the French help section to check
do the same again by renaming the help language files in the English directory & visiting French help section ..
#7
Not Solved
Well, in both cases I got the english text; that means that the helpdocs.php files are not taken into account, but that is in the Data Base helpdocs table where there is only the english text.
So the problem is either in the DB (the usetranslation and enabled fields are all set to 1) or the misc.php (my favorite culprit!).
Thanks.
#8
Not Solved
Do you mean the title/content of help documents? If yes, they're unfortunately not possible to translate in default MyBB, you need to use this plugin: http://mybbhacks.zingaburga.com/showthread.php?tid=1732 (+ XThreads).
#9
Not Solved
(2014-02-27, 09:18 PM)Destroy666 Wrote: Do you mean the title/content of help documents? If yes, they're unfortunately not possible to translate in default MyBB, you need to use this plugin: http://mybbhacks.zingaburga.com/showthread.php?tid=1732 (+ XThreads).

Thanks to both of you. I will try your plugin tomorrow, since it's too late here to start implementing the stuff.
I will tell you the result of this.
You saved my night !
#10
Not Solved
Sorry for answering lately, had more urgent duties this WE.
1) I am wondering why:
Quote: unfortunately not possible to translate in default MyBB
while some guy wrote lines of code in misc.php to generate an URL such as [url=http://condor-velivole.eu/mybb/misc.php?action=help&my_post_key=c05xxx&language=french]/url] pointing clearly to a french translation and that other guy from the french community to provide the translated strings of the Help Documents???
I don't see the rationale behind that!
May be you could explain, I am not sufficiently fluent in PHP to decode fully misc.php?action=help.

2) I uploaded both Xthreads and the Helpdoc plugin, but the result is unchanged : still english in both cases.

3) Xthreads seems a nice piece of code to create new thread types; hope to give a try later.
Thanks for your time.


Forum Jump:


Users browsing this thread: 1 Guest(s)