Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 7 Years, 9 Months, 1 Week ago SQL Error 1142
#1
Solved: 7 Years, 9 Months, 1 Week ago
Hello all,

After a couple of years without problems, my MyBB forum is not working anymore. I made no changes at all on it and since yesterday afternoon no one can access it (an error message appears when I try to access the index page). I cannot even access the admin section.

I called my host but it seems they did not do anything. I tried to fix it myselft by modifying some of the values on the "mybb_sessions" on the "iud" line, but nothing worked.

Unfortunately, I don't remember the version of MyBB I have installed. What I know is that, unfortunately,I haven't upgraded it in a while.

Screenshot : check attachment

   

Do you have any suggestions ?

Thanks,
cachip
#2
Solved: 7 Years, 9 Months, 1 Week ago
You or your host seam to have changed the database credentials. Please check the values in inc/config.php.
[Image: banner.png]
#3
Solved: 7 Years, 9 Months, 1 Week ago
Hi,

Thanks for your answer.

I've checked the file.
It seems that the credentials are alright (the username in the config file is the same that appears on the error message).

   
#4
Solved: 7 Years, 9 Months, 1 Week ago
The error message says they are not correct. If you are unsure please ask your host.
[Image: banner.png]
#5
Solved: 7 Years, 9 Months, 1 Week ago
The fact is I have a wordpress running on the same database and it's still working.

Hence the credentials should still be correct, shouldn't they ?
#6
Solved: 7 Years, 9 Months, 1 Week ago
The credentials are correct, but the MySQL user doesn't have permission to execute INSERT commands. If you contact your host they should be able to point you in the right direction. Usually this can be changed from your web host's control panel.
No longer involved in the MyBB project.
#7
Solved: 7 Years, 9 Months, 1 Week ago
Hey guys,

I changed the user password throught my host's panel (and then on my config files). It's now working fine. Thanks for your help.

Cachip.


Forum Jump:


Users browsing this thread: 1 Guest(s)