Not Solved Google SEO HTTPS?
#1
Not Solved Bug 
Hi All,

I recently purchased a SSL but unfortunately it doesn't work with the google SEO plugin for some reason.

http://mods.mybb.com/view/google-seo (This is the plugin)

I set the board url to HTTPS and changed the .htaccess "http://" to "https://". Unfortunately it still gives an error that my board URL is set correctly "https://www.site.com" but that I am still using "http://www.site.com"

Any of you have experience with this?
Everything works with the SSL only there seems to be a mismatch with the Google SEO plugin.

Thanks!
Reply
#2
Not Solved
Do you configure on your admin CP your preferences to board url ?

Because so many plugins and mods, have to take that value of your db instead.

bburl by default, so i think if you configure there https protocol have to work., cheers.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#3
Not Solved
(2014-04-15, 05:30 PM)Dark Neo Wrote: Do you configure on your admin CP your preferences to board url ?

Because so many plugins and mods, have to take that value of your db instead.

bburl by default, so i think if you configure there https protocol have to work., cheers.

Hi Neo, yes I configured the bburl through the adminCP Smile
Reply
#4
Not Solved
I use SSL on my board for secure functions like login, but I don't use SEO URLs (I only use 404, sitemap and meta) so I never bothered debugging it.

I believe the problem is in SEO Redirect -- can you try turning off SEO Redirect as a test?
Reply
#5
Not Solved
This user has been denied support. This user has been denied support.
Are you using Apache? Your site URL?

Google SEO currently checks $_SERVER["HTTPS"] on.

If that's not set or set to something else, can you put a print_r(array($_SERVER["HTTPS"], $_SERVER["SERVER_PORT"])); anywhere?
Reply
#6
Not Solved
You may also want to take a look at SSL Switcher which modifies the value of $mybb->settings['bburl'] based on whether connecting via http or https.
Reply
#7
Not Solved
This user has been denied support. This user has been denied support.
The SSL Switcher uses the same check as Google SEO does; if it does not detect that SSL is in use (due to the webserver configuration or whatever) it won't work.

Need more info here regarding your setup/site. It's not the fault of the plugins... (although I guess the check could be extended to the port number, if it's set...)
Reply
#8
Not Solved
(2014-04-16, 09:38 PM)frostschutz Wrote: The SSL Switcher uses the same check as Google SEO does; if it does not detect that SSL is in use (due to the webserver configuration or whatever) it won't work.

Need more info here regarding your setup/site. It's not the fault of the plugins... (although I guess the check could be extended to the port number, if it's set...)

Is there a way I can manually switch the plugin to go HTTPS rewrite mode?
Reply
#9
Not Solved
Sorry if this is gravedigging but i'm having the same problems as Senethic.

This in plugins
Board URL is set to 'https://www.mywebsite.org', but you currently seem to be on 'http://www.mywebsite.org'. A wrong Board URL setting may cause problems with Redirect.

And then when I try to load a forum section that should be https://mywebsite.org/forum-forumname
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

board url starts https
homepage url starts https
first rewrite rule for Google SEO was changed to https

Okay, my solution was pretty simple.

My hosting providers SSL port is not 443, so I edited line 45 of inc/plugins/google_seo/redirect.php


    if($_SERVER['HTTPS'] != "off" && ($_SERVER['HTTPS'] || $_SERVER['SERVER_PORT'] == 443))


and changed 443 to the port my host uses and it's fixed the issue, it follows the rewritten links and everything seems to be as before.
Reply
#10
Not Solved
(2014-09-01, 07:34 PM)p00lz Wrote: Sorry if this is gravedigging but i'm having the same problems as Senethic.

This in plugins
Board URL is set to 'https://www.mywebsite.org', but you currently seem to be on 'http://www.mywebsite.org'. A wrong Board URL setting may cause problems with Redirect.

And then when I try to load a forum section that should be https://mywebsite.org/forum-forumname
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

board url starts https
homepage url starts https
first rewrite rule for Google SEO was changed to https

Okay, my solution was pretty simple.

My hosting providers SSL port is not 443, so I edited line 45 of inc/plugins/google_seo/redirect.php


    if($_SERVER['HTTPS'] != "off" && ($_SERVER['HTTPS'] || $_SERVER['SERVER_PORT'] == 443))


and changed 443 to the port my host uses and it's fixed the issue, it follows the rewritten links and everything seems to be as before.

What port did you use? I added port 53 but that won't work.. ;(
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)