[Pushed] Show Posted Images/Videos To Guests
#1
Quote:Show Posted Images To Guests: Setting this to yes will allow guests to see images that have been posted.

Show Posted Videos To Guests: Setting this to yes will allow guests to see videos that have been posted.

When the above settings are set to "NO" it shows the image and video links instead of the image/video.. this doesnt help, its pretty useless this way.... they can still see those content by clicking that link.... it should rather disable the entire img/video tag and thereby remove the entire content....

[Image: Test.png]
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#2
but this is not bug...
you need post this in suggestions folder and not here...
Reply
#3
(2014-07-03, 07:26 AM)martec Wrote: but this is not bug...
you need post this in suggestions folder and not here...

yes me too thought of it... but its not doing what it supposed to do - it only removes the img tag but not the content...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#4
I would consider it a bug. If they don't have permission to view the image, I would not consider them to have permission to know its url.
Reply
#5
(2014-07-03, 12:39 PM)dragonexpert Wrote: I would consider it a bug. If they don't have permission to view the image, I would not consider them to have permission to know its url.

bug?

https://github.com/mybb/mybb/issues/449#...t-45249923
https://github.com/mybb/mybb/issues/449#...t-45279549

Quote:The first is some form of alternate parsing for disabled image/video MyCode. I was thinking parse them as a link if disabled.

I just consider it as bug to not work as planned. If it was planned to show the link when it is disabled, then personally is not bug.
Reply
#6
(2014-07-03, 12:39 PM)dragonexpert Wrote: If they don't have permission to view the image, I would not consider them to have permission to know its url.

this is exactly what I am trying to convey..

(2014-07-03, 01:03 PM)martec Wrote: If it was planned to show the link when it is disabled, then personally is not bug.

yes. I am still not sure how it is set to work.... but I suggest that it would be better to hide the link as well rather than just the img tag...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#7
Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/1010

Thanks for contributing to MyBB!

Regards,
The MyBB Group
All my plugins are available for free at MyBB Extend and on my GitHub. MyBB-Plugins.com has been closed and none of my plugins are officially maintained or supported.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)