Not Solved Unapproved Threads Color problem
#1
Not Solved
Hello
I have installed Square theme and there's an issue with unapproved threads. Unapproved threads are in red color when I open the thread but from outside it looks like a normal thread. In simple words, I can only come to know about unapproved threads after opening it. Please help me!

Thanks

Is there anyone who can help me out?
Reply
#2
Not Solved
ACP > Templates & Styles > Templates > Square Templates > Forum display

Open and replace this 3 templates with the content below

forumdisplay_thread

<tr>
	<td align="center" class="{$bgcolor}{$thread_type_class}" width="2%"><img src="{$theme['imgdir']}/{$folder}.gif" alt="{$folder_label}" title="{$folder_label}" /></td>
	<td align="center" class="{$bgcolor}{$thread_type_class}" width="2%">{$icon}</td>
	<td class="{$bgcolor}{$thread_type_class}" width="20%">
		{$attachment_count}
		<div>
			<span>{$prefix} {$gotounread}{$thread['threadprefix']}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}"><strong>{$thread['subject']}</strong></a></span>
			<div class="author smalltext">Started by: <strong>{$thread['profilelink']}</strong></div>
		</div>
	</td>
	<td align="left" class="{$bgcolor}{$thread_type_class}" width="15%">{$thread['multipage']}</td>
	{$rating}
	<td align="left" class="{$bgcolor}{$thread_type_class}" width="15%"><i style="font-size: 14px;" class="fa fa-pencil fa-fw" title="Replies"></i>: <a href="javascript:MyBB.whoPosted({$thread['tid']});">{$thread['replies']}</a>{$unapproved_posts}<br /><i style="font-size: 14px;" class="fa fa-eye fa-fw" title="Views"></i>: {$thread['views']}</td>
	<td class="{$bgcolor}{$thread_type_class}" style="white-space: nowrap; text-align: left;" width="15%">
		<span class="lastpost smalltext">{$lastpostdate} {$lastposttime}<br />
		<a href="{$thread['lastpostlink']}">{$lang->lastpost}</a>: {$lastposterlink}</span>
	</td>
{$modbit}
</tr>

forumdisplay_thread_rating

<td align="left" class="{$bgcolor}{$thread_type_class}" id="rating_table_{$thread['tid']}" width="20%">
		<ul class="star_rating{$not_rated}" id="rating_thread_{$thread['tid']}">
			<li style="width: {$thread['width']}%" class="current_rating" id="current_rating_{$thread['tid']}">{$ratingvotesav}</li>
		</ul>
		<script type="text/javascript">
		<!--
			Rating.build_forumdisplay({$thread['tid']}, { width: '{$thread['width']}', extra_class: '{$not_rated}', current_average: '{$ratingvotesav}' });
		// -->
		</script>
	</td>

forumdisplay_thread_modbit

<td class="{$bgcolor}" align="center" style="white-space: nowrap" width="1%"><input type="checkbox" class="checkbox" name="inlinemod_{$multitid}" id="inlinemod_{$multitid}" value="1" {$inlinecheck}  /></td>

Now, go to ACP > Templates & Styles > Styles > Square

Open global.css, and search ".trow1" and ".trow2", replace both with this code:

.trow1 {
	background: #FAFAFA;
	border-top: 1px solid #EBEBEB;
	border-bottom: 1px solid #FFFFFF;
}

.trow2 {
	background: #FAFAFA;
	border-top: 1px solid #EBEBEB;
	border-bottom: 1px solid #FFFFFF;
}
I don't give support on PM.
Reply
#3
Not Solved
Awesome! Thanks a million. Worked like a charm Smile
Reply
#4
Not Solved
Next time if you have any issue using one of my themes, it's better to you and me to create a new reply in the square theme thread, inside Theme Releases.

Greetings!
I don't give support on PM.
Reply
#5
Not Solved
Sure I will do that. I was not aware about it. Anyways Thanks again.
Take care
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)