Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] Firefox thinks I am using the wrong password.
#1
Like the title says, when I use firefox, it says that i've entered an incorrect password, while other browsers (opera and IE) work fine.

This is happening on multiple computers.
#2
Your typing the wrong password. There are no problems with password authorization.
#3
I'm sorry if this is annoying you, but I am having problems with MyBB, and would like some suggestions to solve them.

You don't think I have tried logging in many more times? You think that when I use Firefox I type differently then on Opera or IE?

I am not typing the wrong password, there is something wrong with how it Firefox is handling the authentication, and I would like to know if anyone else has had this problem, and if anyone else has a solution, not just to be told that you think I typed the wrong password.

Now for the problem..


Firefox says I am using the wrong password, while other browsers do not. Has this happened to anyone else, and does anyone have a solution?
Also, it is not my Firefox installation, as this is happening on other computers..
#4
1) There have be NO other reports by hundreds of thousands of users using out product that logging in doesn't work in firefox. It works for everyone EXCEPT for you. And even more so since you say it doesn't work on one browser I am led to believe your typing your password wrong or something your doing is messing it up.

2) The code for password authorization is perfectly fine. I have NO solutions for you. Nothing. The only POSSIBLE SOLUTION is to type the correct password.
#5
Clear all cache and cookies. Also make sure you don't have any auto-fill enabled. What version of Firefox are you on? It's not Mybb...it's your computer and/or firefox.
#6
well I figured out the problem.

When you have password storage on on firefox, even if there is nothing stored, it clears the password field before it submits for some reason if you tell it not to remember your password..
#7
You are using the quick login? If you click out of the box then in it again it will clear the input field. I think this should be changed though.
#8
Is it actually saying "Invalid Password" or does it just not recognize your login? (eg. the welcome panel continues to say "Hello Guest")
Dennis Tsang
Former MyBB Team Member
Web: http://dennistt.net
#9
Can't say I didn't tell you so. Crakter, I think it should only reset if the password box text == default.

Also, MyBB should prevent users from using the password 'password'.
#10
It's happening when you press [ENTER] via the quick login field on the index. I've come across this before and only managed to take a deeper look at it whilst I was away.

I'll ensure we get it fixed for the next version, but right now I'll just move it to the bug reports forum.

Regards,
Chris


Forum Jump:


Users browsing this thread: 1 Guest(s)