[Pushed] Editor - problem with styling
#1
How to reproduce:
1) copy text from website into editor
2) click on Post Thread
3) check your post - you can see ..... etc.
   

4) OK, now click on "Full edit" - and check your text again - you cannot see ..... 
   

5) ok, click on "Update post"
6) Check your updated post - now you can see again .....  


You can see it here: http://community.mybb.com/thread-157489-...pid1092551


PS - same problem with quick edit
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#2
There are 2 ways to fix it:
1- Edit SCEditor:
in jscripts/bbcodes_sceditor.js
find:
			if(element[0].nodeName.toLowerCase() !== 'font' || !(font = element.attr('face')))
				font = element.css('font-family');
Replace:
if(element[0].nodeName.toLowerCase() !== 'font' || !(font = element.attr('face')))
				font = element.css('font-family');

			fonts = font.split(',');
			font = fonts[0];

2: Edit Cass Parser: (it is better than 1)
in inc/class_parser.php
find:
$nestable_mycode['font']['regex'] = "#\[font=([a-z0-9 ,\-_]+)\](.*?)\[/font\]#si";
replace to:
$nestable_mycode['font']['regex'] = "#\[font=([a-z0-9 ,\-_'\"]+)\](.*?)\[/font\]#si";
Reply
#3
Thanks, I will test it. I hope that mybb team will push this into github and you will send your PR Wink
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#4
Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/1221

Thanks for contributing to MyBB!

Regards,
The MyBB Group
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)