Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
xmlhttp_buddyselect issue / question
#1
After revamping private_send template i have noticed that my changes to buddy popup (xmlhttp_buddyselect) aren't applied. After looking at usercp.js i have noticed that buddyselect function points to xmlhttp.php?action=get_buddyselect (which is fetching xmlhttp_buddyselect template). That template was modified (tables are replaced with divs) but (after looking at xmlhttp.php?action=get_buddyselect) default template structure is still there:

<!-- start: xmlhttp_buddyselect -->
<table border="0" cellspacing="1" cellpadding="4" class="tborder" style="width: 300px;">
	<thead>
		<tr>
			<td class="thead">
				<div class="float_right" style="margin-top: 3px;"><span class="smalltext"><a href="#" onclick="UserCP.closeBuddySelect(true); return false;">Close</a></span></div>
				<div><strong>Select Buddies</strong></div>
			</td>
		</tr>
	</thead>
	<tbody>
		<tr>
			<td class="trow1 smalltext">To add one or more of your buddies as recipients, select them below and click OK.</td>
		</tr>
		<tr>
			<td class="trow2">
				<div style="height: 200px; overflow: auto;" >
				<table border="0" cellspacing="1" cellpadding="4" class="tborder" style="border: 0; width: 270px;" align="right">
				
				<!-- start: xmlhttp_buddyselect_offline -->
					<tr>
						<td class="trow1" onmouseover="this.className='trow2';" onmouseout="this.className='trow1';"><label><input type="checkbox" style="vertical-align: middle;" id="checkbox_124" onclick="UserCP.selectBuddy('124', 'Abstracte');" /> <img src="/buddy_offline.png" alt="(Offline)" title="Offline" style="vertical-align: middle;" /> Abstracte</label></td>
					</tr>
<!-- end: xmlhttp_buddyselect_offline -->
				</table>
				</div>
			</td>
		</tr>
		<tr>
			<td class="trow1">
				<div class="smalltext"><strong>Selected recipients</strong></div>
				<div id="buddyselect_buddies" class="smalltext" style="padding-left: 10px; height: 50px; overflow: auto;"></div>
				<div style="text-align: right;"><input type="button" class="button" value="OK" onclick="UserCP.closeBuddySelect();" /> <input type="button" class="button" value="Cancel" onclick="UserCP.closeBuddySelect(true);" /></div>
			</td>
		</tr>
	</tbody>
</table>
<!-- end: xmlhttp_buddyselect -->


I have deleted default 1.8 theme but that output isn't changed (and right template is edited since output clearly displays <!-- end: xmlhttp_buddyselect -->).

I'm running this at localhost (uniserver) with PHP Version 5.4.19.

Edit: it's xmlhttp.php related ,i'll report it as issue


Forum Jump:


Users browsing this thread: 1 Guest(s)