[Rejected] Post editor - parser bug for emoticons
#1
copy these

:S :S :S :S

then go to editor, paste it and press enter many times.
Try fiew times and in different ways (eg. type it yourself ect) as it may sometime not work at first.
It will just start messing up at some point and insert new emoticons by itself.
Reply
#2
Did you try it with latest github version? Because I fixed this issue 3 days ago
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#3
(2014-08-23, 07:10 AM)Eldenroot Wrote: Did you try it with latest github version? Because I fixed this issue 3 days ago

Just tested now with feature branch to make sure. unfortunately this bug is still there.

If you put fiew emotikons in a row, then delete space from last one and then press enter fiew times,
it begin to insert more and more emoticons by itself while you press enter. Sometime even in random place.

Try with :s :s :s :s
Reply
#4
@avril you tested too in http://www.sceditor.com/ ?
if you can reproduce same issue, so sceditor bug and not mybb bug...
Reply
#5
(2014-08-23, 08:13 AM)martec Wrote: @avril you tested too in http://www.sceditor.com/ ?
if you can reproduce same issue, so sceditor bug and not mybb bug...

yes i did just now, and i cant reproduce this bug there, whats more i noticed that this editor does not add spaces around emoticon while mybb editor do this, and it may have something to do with the bug because exacly when delete such space - strange things begin to happen.
Reply
#6
i can´t reproduce this issue here (community.mybb)...
this is in only of github?
Reply
#7
neither can i , the only thing that does , when you delete the space from the last smiley, it is turning him into text

but if you click "Preview Post" he will look like a smiley...
Reply
#8
related thread (as Eldenroot mentioned) => Smilies are displayed as codes in WYSIWYG Editor Mode
Reply
#9
but smile only work with whitespace ...
because we using emoticonsCompat mode
http://www.sceditor.com/documentation/options/

Quote:emoticonsCompat

emoticonsCompat Bool Defaults to false

Enables or disables emoticons compatibility mode.

When this is enabled, emoticons must be surrounded by whitespace or EOL characters. For example, if you have an emoticon with the code :/, in compatibility mode it will not replace the :/ in http://.

Compatibility mode currently has limited As You Type emoticon conversion support. EOL characters are not recognised as whitespace with AYT conversion so only emoticons surrounded by whitespace will be converted. This does not affect non-AYT conversion which will still work as normal.

this mode is necessary to avoid this issue http://community.mybb.com/thread-154357.html https://github.com/mybb/mybb/issues/691
Reply
#10
copy these

:S :S :S :S

then go to editor, paste it and press enter many times. Cant reproduce it still ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)