Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 7 Years, 5 Months ago Help button in menu bar
#1
Solved: 7 Years, 5 Months ago
Hi there,

I'm a dutch teenager who is starting up a mybb forum on this domain link: http://portal.leerwel.nl/forum/ .
I'm using mybb 1.6.15, Tranquil Theme, and I'm happy about it.
I've got just one problem, my "Help" button in the menu bar of my forum, doesn't work.
It doesn't gives a real error, but just a blank page.
Click here for a screenshot of it.
Because it's a dutch version, their is a dutch translation of the helpdocuments.
I think this might be the problem. It's weird, because yesterday it was still working.
I've already reset the header templates etc. and the menu button is linking to the right page.
I've don't writing in the helpdocs files, en in the Admin CP, Everything seems fine.


This is the script of the header template from the Tranquil Theme.
<script type="text/javascript">
if (document.body.id == 0) {document.body.id = "forums";} 
</script>

<div id="header">
<div id="header_wrap">

<div class="logo"><table style="width:100%;"><tr><td><a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" /></a></td><td style="width:{$mybb->settings['header_width']}%;">{$mybb->settings['header_code']}</td></tr></table></div>

<div class="search_box">

<a href="search.php" class="adv_search">Geavanceerd</a>

<form method="post" action="search.php" style="">
<input type="hidden" name="action" value="do_search" />
<input type="hidden" name="tid" value="{$thread['tid']}" />
<input type="text" class="textbox" name="keywords" value="Zoeken..." onfocus="if(this.value == 'Zoeken...') { this.value = ''; }" onblur="if(this.value=='') { this.value='Zoeken...'; }" " />

<input class="complete" name="search" type="image" src="{$theme['imgdir']}/search.png" value="{$lang->search_thread}">

</form>

</div>

<div id="bridge">
<a href="#" class="panel_toggle">
Paneel
</a>
<div class="menu">
<ul>

                                       <li><a href="{$mybb->settings['bburl']}/index.php" class="Forums">{$lang->toplinks_forums}</a></li>
<li><a href="{$mybb->settings['bburl']}/memberlist.php" class="Memberlist">{$lang->toplinks_memberlist}</a></li>
<li><a href="{$mybb->settings['bburl']}/calendar.php" class="Calendar">{$lang->toplinks_calendar}</a></li>
                                       <li><a href="{$mybb->settings['bburl']}/showteam.php">Medewerkers</a></li>
<li><a href="{$mybb->settings['bburl']}/misc.php?action=help" class="Help">{$lang->toplinks_help}</a></li>
                                       <li><a href="{$mybb->settings['bburl']}/search.php" class="Search">{$lang->toplinks_search}</a></li>
                                       <li><a href="https://leerwel.uservoice.com">Services</a></li>
                                       <li><a href="mailto:[email protected]">Contact</a></li>
                                       
</ul>
</div>
</div>

</div>
</div>

<div id="container">
<a name="top" id="top"></a>
<hr class="hidden" />
<div id="panel">
{$welcomeblock}
</div>
<hr class="hidden" />
<div id="content">
<navigation>
{$board_messages}
{$pm_notice}
{$bannedwarning}
{$bbclosedwarning}
{$unreadreports}{$unreadpmreports}
{$pending_joinrequests}
<br />

Can please someone help me?
If you need anything else from the script to see, please quest me.
I can also give a test account when you need it:

Test account username: Test password: test123

Thanks already,

Florian
#2
Solved: 7 Years, 5 Months ago
provide a test user account so that someone can check it.
if you change forum default language to English then does the help feature work normal ?
#3
Solved: 7 Years, 5 Months ago
(2014-08-28, 05:04 PM).m. Wrote: provide a test user account so that someone can check it.
if you change forum default language to English then does the help feature work normal ?
No also when I change the default language it gives the same problem.
Test account is added in the discussion.

Test account username: Test password: test123

Thank you already,

Florian
#4
Solved: 7 Years, 5 Months ago
^ can you check server (error) log available at web host control panel to find the cause ..
#5
Solved: 7 Years, 5 Months ago
(2014-08-28, 05:23 PM).m. Wrote: ^ can you check server (error) log available at web host control panel to find the cause ..

PHP Fatal error: Call to undefined function control_object() in /var/www/vhosts/portal.leerwel.nl/htdocs/forum/inc/plugins/xthelpdocs.php on line 62, referer: http://portal.leerwel.nl/forum/index.php

I think this is the right one, do you have an idea what the problem might be?

thanks,

Florian
#6
Solved: 7 Years, 5 Months ago
^ can you disable xthreads help docs plugin (xthelpdocs.php) and check if the help feature works as expected
#7
Solved: 7 Years, 5 Months ago
Yes it works as expected, is the only thing I have to do is disable the plugin? Or do I have to fix the error in the plugin? Smile Thank you very much already! Really it's where i'm lucking for for days!

Florian
#8
Solved: 7 Years, 5 Months ago
^ if you do not need help documents in English language then no need to use that plugin (XThreads help docs)

however, referred error appears to be due to not using its base plugin XThreads
#9
Solved: 7 Years, 5 Months ago
Oke, thank you very much!


Forum Jump:


Users browsing this thread: 1 Guest(s)